Confusing message in autosave (or save) message popup window for non UTF-8 encoded messages

RESOLVED DUPLICATE of bug 328938

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 328938
10 years ago
10 years ago

People

(Reporter: Lyu ABE, Unassigned)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11
Build Identifier: 2.0.0.9 (20071031) - French language installation

This bug happens when composing a message using non UTF-8 characters. When thunderbird performs an "auto-save" operation of the message being composed (so that a copy of the message is saved in the "draft" folder), or even if you hit "CTRL+s", or use the "File>Save" menu, a popup window displays the following message (translated from french) "Your message contains unknown characters for the chosen encoding. Although you can choose a different character encoding, it is usually not risky to use unicode encoding (UTF-8) for messages. If you choose to send it using this encoding, note that characters not handled by it will display as question marks and will not be understandable by the recipient." and the popup window buttons are "Envoyer en UTF-8" (Send in UTF-8), "Envoyer tout de meme" (Send anyway), "Annuler" (Cancel). Which is very confusing, because it should display "Save in UTF-8", "Save anyway" and "Cancel".

The same kind of message displays if you cancel the previous operation, and decide to destroy the compose window. A popup window appears letting you know that a message "is being sent", and displays the two buttons "Wait" and "Quit". If you hit "Quit", then your message is lost.


Reproducible: Always

Steps to Reproduce:
1.Compose a new email.
2.Write some text.
3.Choose "Options>Character Encoding>Japanese (ISO-2022-JP)" (for example).
4.Let the message auto-save (if enabled), or hit "CTRL+s".
Actual Results:  
The popup window displays a message asking if you want to "Send in UTF-8" the message. If you hit "Send" then the message is saved in the "Draft" folder.

Expected Results:  
The popup window should display the same message using "Save" instead of "Send". 

Similarly for the message when you want to destroy the composing window: it should be more relevant (see last part of the "Details" section).
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0

Comment 1

10 years ago
Bug 410333 makes it a non issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 328938
You need to log in before you can comment on or make changes to this bug.