./configure makes irrelevant error when libxt-dev is not installed

RESOLVED INVALID

Status

RESOLVED INVALID
11 years ago
8 months ago

People

(Reporter: zwnj, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: helpwanted)

(Reporter)

Description

11 years ago
I just tried to re./configure an updated cvs checkout, and I got this error:

...
checking for sys/int_types.h... (cached) no.
configure: error: Could not compile basic X program.

after installing libxt-dev, I got no error, but this is part of output:

...
checking for sys/int_types.h... (cached) no
creating mozilla-config.h
...

So, int_types is not a problem in configure (as mentioned on some emails), and the error doesn't say anything about libxt, and I had libx11-dev installed.

As many people had such problem, would you please make more appropriate error on this case?

Comment 1

11 years ago
Patches accepted.
Whiteboard: helpwanted
(Reporter)

Comment 2

11 years ago
Well, the problem is here and I have no idea how to fix it:

    AC_TRY_COMPILE([
        #include <stdio.h>
        #include <X11/Xlib.h>
        #include <X11/Intrinsic.h>
    ],
    [
        Display *dpy = 0;
        if ((dpy = XOpenDisplay(NULL)) == NULL) {
            fprintf(stderr, ": can't open %s\n", XDisplayName(NULL));
            exit(1);
        }
    ], [],
    [ AC_MSG_ERROR([Could not compile basic X program.]) ])

Can we list all necessary X libraries and check them for inclusion?

I'm not familiar with aclocal stuff.  Behdad, do you have any idea?

Comment 3

11 years ago
IIRC this is broken AC_PATH_XTRA stuff.  What we do in cairo is to check for xlib using pkg-config first.  That should help.

Comment 4

6 years ago
Just did hit this bug, while trying to bisect between Firefox 17 and Firefox 20:
 - configure:27083:35: fatal error: X11/Intrinsic.h: No such file or directory

(build system doesn't check for libXt-devel (X11/Intrinsic.h)

Comment 5

3 years ago
Quite possibly irrelevant after 8 years.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.