Closed Bug 416832 Opened 14 years ago Closed 9 years ago
History count property is quite confusing and should be renamed
in BrowserHistory we have a count property that is really a !isEmpty property since it returns 1 if we have some item in history, 0 otherwise. count name is quite confusing, mainly for third party users (extension developers), they could expect it to be the count of pages into the history. We should change that into isEmpty, or something similar, and should be done before final, to avoid breaking extensions. Due the change we should clearly fix all callers and comments.
notice that in some file we have written in comments "count: the number of entries in global history" (argh!). i'll probably fix some comment in Bug 376706 since i'm modifying BrowserHistory and test_browserhistory, that have really bogus comments (so it's quite confusing for us too).
notice: we don't do real count because it is slow. Actually doing a count(*) in historyvisits with 130000 visits takes about 30ms, we should state if that's a perf killer, based on actual usage of that property.
Doesn't block Firefox 3, but it seems like a sensible/simple change.
Flags: blocking-firefox3? → blocking-firefox3-
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h". In Thunderbird 3.0b, you do that as follows: Tools | Message Filters Make sure the correct account is selected. Click "New" Conditions: Body contains places-to-b-and-h Change the action to "Delete Message". Select "Manually Run" from the dropdown at the top. Click OK. Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter. Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
we removed .count some time ago.
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.