If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

From what account is mail, not showing in sent folder

RESOLVED DUPLICATE of bug 402332

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 402332
10 years ago
7 years ago

People

(Reporter: Nicolas, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.6) Gecko/20070802 Iceape/1.1.4 (Ubuntu-1.1.4-1ubuntu2)
Build Identifier: Mozilla Application Suite

Really simple bug:
When you activate the column "Account" for displaying the account who is related to an email, that column doesn't show anything in sent folder.
I think thats happen because it logs from what account is a message received, but doesn't log from what SMTP server is released.

Reproducible: Always

Steps to Reproduce:
1.Enable the column view: Account
2.Send some email
3.Look in the "Sent" folder, there is no stamp from what account.
Actual Results:  
This is important on large business where we have internal and external mail and the users want to know the history of sent mail, from what account.

Expected Results:  
The software must log from what account is sending an email, not only receiving it.
This bug is X-Account-Key: version of Bug 383846(X-Mozilla-Keys:).

Account column displays account name obtained via account number in X-Account-Key: header. And "Copy to Sent folder" won't generate X-Account-Key: header.

When POP3, no problem in writing X-Account-Key: header, unless account number change occurs by re-definition of account. (Same situation as X-Account-Key: of received mail)
But when IMAP, different account number is assigned usually, because account definition procedure(order of account definition) is usually diffferent when different PC. What should be held as "Account information" of a sent mail when IMAP? (See Bug 264626 for X-Identity-Key: related issue on draft mail when IMAP)
Note: When IMAP, X-Account-Keys: is currently not held in mail data even when received mail.

So I think enhancement for local mail folder is sufficient, if enhancement request of X-Account-Key: header when "Copy sent mail in Sent folder".
But "what should be" in next cases should be considered.
 (For news post)
 - X-Account-Key: is really required or not.
   If X-X-Account-Key: should be written when saved in local mail folder,
   what should be written in it.
 (For IMAP)
 - Move/Copy from IMAP folder to other IMAP folder of other IMAP account
 - Move/Copy from IMAP folder to local mail folder, by hand or by filter

I feel following is better when sent mail.
 (1) Enhancement of "Sent mail" or "Received mail" indicator in
     X-Mozilla-Status:/X-Mozilla-Status2: etc.
 (2) Enhancement in acquiring of account information from mail address in
     "From:" header.
     mail-address in From: => Identity number => Account number => Account name
 (3) If sent mail, display (2) in account column.
Above can be a solution of problem of Bug 264626 too.
I think almost all logic for (2) is already implemented by "Reply to Self" function.

Comment 3

10 years ago
It's not only the Sent folder, it's all IMAP folders. I think this is as designed and not in need of change - imap accounts can be used from many computers account is relative. 

Comment 4

10 years ago
Should have read ", so which account is a relative concept".

Comment 5

10 years ago
Related to/duplicate of bug 402332?
dup of bug 402332?
Severity: major → normal
Whiteboard: dupme
(In reply to comment #6)
> dup of bug 402332?
I agree... 

Reproducibile issue here on my pop3 sentbox folder.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 402332
Cleanup *dupeme* whiteboard flag from bugs that are marked as Resolved
Duplicate!
Whiteboard: dupme
You need to log in before you can comment on or make changes to this bug.