If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Session no longer gets restored

RESOLVED WORKSFORME

Status

()

Firefox
Session Restore
--
critical
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Roman R., Unassigned)

Tracking

Trunk
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008020604 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008020604 Minefield/3.0b4pre

I recently updated Firefox 3 beta with the latest nightly build (Feb 11, 2008) and noticed that previous session no longer gets restored (I had many tabs open). Reverting to an older version for which Session Restore worked (Feb 06, 2008) results in successful loading of the session.

Reproducible: Always




The Feb 06 build I have was obtained from http://www.wg9s.com/mozilla/firefox/
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021114 Minefield/3.0b4pre

- Save and Quit WFM
- Restoring after crash WFM
- When Minefield starts, show my windows and tabs from last time WFM
- History -> Recently Closed Tabs WFM

Please give more detailed steps to reproduce.
(Reporter)

Comment 2

10 years ago
Ria, the only thing that was clear to me was your last sentence. If the block above was for me, then please explain what it means (start with WFM).

Comment 3

10 years ago
WFM stands for "Works for me".
(Reporter)

Comment 4

10 years ago
Thank yo, Cww.

(In reply to comment #1)
> Please give more detailed steps to reproduce.

I start FF with -ProfileManager switch, choose one I want, and I get a FF with one empty tab. However, doing the same with Feb 06 build loads a bunch of tabs I had open before I closed FF. I don't know what other details to provide. The profile I am using is one I imported from FF 2.

Comment 5

10 years ago
This was broken in a few hourly builds around that date.  Also, you should only get builds (or any release for that matter) from mozilla websites, not some random site.  Who knows what they could have done with that build.
(Reporter)

Comment 6

10 years ago
It's not a random site. It belongs to a contributor to Mozilla.

So, is there a bug filed for this that I can monitor to see when I can use a newer build? If the new FF can't deal with an old profile, as far as Session Restore is concerned, this could be upsetting to more people down the road.

Comment 7

10 years ago
I can't find it but beta 3 is supposed to be released today and is unofficially released right now.
(In reply to comment #6)
> So, is there a bug filed for this that I can monitor to see when I can use a
> newer build? If the new FF can't deal with an old profile, as far as Session
> Restore is concerned, this could be upsetting to more people down the road.

I haven't seen such an issue all the last time. You should safely update to the newest build when it is released. If it's not fixed for you it would be nice if you could add the sessionstore.js to this bug. Then we also can run a test. Thanks.
Version: unspecified → Trunk
(Reporter)

Comment 9

10 years ago
First of all, my sessionstore.js happens to contain some things I wouldn't want others to see :)

Second, here's some food for thought. I just installed the Feb 12 build (used installer from mozilla.org) and noticed that upon exit, it doesn't modify sessionstore.js. Suspecting something fishy, I created a new profile to test this, configured FF to open previously opened tabs and windows, and... it never created sessionstore.js in the new profile. It doesn't give a damn about restoring sessions! I tried it 3 times.
(Reporter)

Comment 10

10 years ago
History doesn't get displayed, and bookmarks don't get stored. These aren't for this bug report but still...

I'll wait for the beta 3 release. Can somebody point me to the unofficial copy? Maybe I'll prevent Mozilla from embarrassment. :)
Than just modify the sessionstore.js and remove/replace your private sites (if possible). I cannot see this issue on my box even not with a fresh profile. The sessionstore.js is created/updated each time. You could do a console log and have a look for possible JS errors: http://kb.mozillazine.org/Javascript.options.strict
(Reporter)

Comment 12

10 years ago
Good news! I installed the still unofficial beta 3 *into a new directory*, and it works as expected. I wonder if installing into a different directory was important (I used to keep installing pre beta 3 into the same dir that contained beta 2+), but because beta 2 isn't going to be released, I won't spend time investigating this. Later somebody will have to install FF 3 Release onto FF 2 and see what happens.

Closing as WFM...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.