Closed Bug 416916 Opened 13 years ago Closed 8 years ago

nsCxPusher::Push should return PR_FALSE in more cases

Categories

(Core :: DOM: Core & HTML, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 834732

People

(Reporter: sicking, Unassigned)

Details

Currently nsCxPusher::Push will return PR_TRUE in a bunch of situations when it's not actually pushing anything. In fact, the only times it returns PR_FALSE is if you try to push more than once using the same pushed, or if you provide a document and we can't get a scriptglobalobject from it.

We should probably fix it to only return PR_TRUE if it successfully pushed a context.
I'm fixing up all this junk in bug 834732.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 834732
Component: DOM → DOM: Core & HTML
You need to log in before you can comment on or make changes to this bug.