Status

()

P3
normal
VERIFIED DUPLICATE of bug 38768
19 years ago
19 years ago

People

(Reporter: scottputterman, Assigned: dcone)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Whenever I try to print something from the browser I crash with the following 
stack:

nsPresContext::SetCompatibilityMode(nsPresContext * const 0x05fbb740, 
nsCompatibility eCompatibility_NavQuirks) line 425 + 36 bytes
DocumentViewerImpl::PrintContent(DocumentViewerImpl * const 0x05cd49d8, 
nsIWebShell * 0x05c1666c, nsIDeviceContext * 0x05eff2a0) line 767
DocumentViewerImpl::DocumentReadyForPrinting() line 1129 + 32 bytes
DocumentViewerImpl::Print(DocumentViewerImpl * const 0x05cd49d8, int 0, _iobuf * 
0x00000000, nsIPrintListener * 0x00000000) line 1445
nsBrowserInstance::Print(nsBrowserInstance * const 0x05c5bd70) line 1220 + 29 
bytes
XPTC_InvokeByIndex(nsISupports * 0x05c5bd70, unsigned int 31, unsigned int 0, 
nsXPTCVariant * 0x0012e110) line 139
nsXPCWrappedNativeClass::CallWrappedMethod(JSContext * 0x03d8a690, 
nsXPCWrappedNative * 0x05c5bbb0, const XPCNativeMemberDescriptor * 0x03d41930, 
nsXPCWrappedNativeClass::CallMode CALL_METHOD, unsigned int 0, long * 
0x04c22e88, long * 0x0012e2c0) line 914 + 43 bytes
WrappedNative_CallMethod(JSContext * 0x03d8a690, JSObject * 0x04d14190, unsigned 
int 0, long * 0x04c22e88, long * 0x0012e2c0) line 200 + 34 bytes
js_Invoke(JSContext * 0x03d8a690, unsigned int 0, unsigned int 0) line 686 + 23 
bytes
js_Interpret(JSContext * 0x03d8a690, long * 0x0012ebfc) line 2487 + 15 bytes
js_Invoke(JSContext * 0x03d8a690, unsigned int 1, unsigned int 2) line 702 + 13 
bytes
js_InternalInvoke(JSContext * 0x03d8a690, JSObject * 0x04d15238, long 80826960, 
unsigned int 0, unsigned int 1, long * 0x0012ed94, long * 0x0012ed34) line 775 + 
19 bytes
JS_CallFunctionValue(JSContext * 0x03d8a690, JSObject * 0x04d15238, long 
80826960, unsigned int 1, long * 0x0012ed94, long * 0x0012ed34) line 2801 + 31 
bytes
nsJSContext::CallEventHandler(nsJSContext * const 0x03d8a820, void * 0x04d15238, 
void * 0x04d15250, unsigned int 1, void * 0x0012ed94, int * 0x0012ed90, int 0) 
line 788 + 33 bytes
nsJSEventListener::HandleEvent(nsIDOMEvent * 0x05efd8e4) line 154 + 64 bytes
nsEventListenerManager::HandleEventSubType(nsListenerStruct * 0x05b18ed0, 
nsIDOMEvent * 0x05efd8e4, nsIDOMEventTarget * 0x05ab2380, unsigned int 8, 
unsigned int 7) line 754 + 19 bytes
nsEventListenerManager::HandleEvent(nsIPresContext * 0x0593e1a0, nsEvent * 
0x0012f424, nsIDOMEvent * * 0x0012f3f0, nsIDOMEventTarget * 0x05ab2380, unsigned 
int 7, nsEventStatus * 0x0012f468) line 1564 + 39 bytes
nsXULElement::HandleDOMEvent(nsXULElement * const 0x05ab2370, nsIPresContext * 
0x0593e1a0, nsEvent * 0x0012f424, nsIDOMEvent * * 0x0012f3f0, unsigned int 1, 
nsEventStatus * 0x0012f468) line 3418
nsMenuFrame::Execute() line 1421
nsMenuFrame::HandleEvent(nsMenuFrame * const 0x04d5f0f8, nsIPresContext * 
0x0593e1a0, nsGUIEvent * 0x0012f8c0, nsEventStatus * 0x0012f7b0) line 343
PresShell::HandleEventInternal(nsEvent * 0x0012f8c0, nsIView * 0x05efbed0, 
nsEventStatus * 0x0012f7b0) line 3616 + 38 bytes
PresShell::HandleEvent(PresShell * const 0x0593f294, nsIView * 0x05efbed0, 
nsGUIEvent * 0x0012f8c0, nsEventStatus * 0x0012f7b0, int & 1) line 3536 + 23 
bytes
nsView::HandleEvent(nsView * const 0x05efbed0, nsGUIEvent * 0x0012f8c0, unsigned 
int 8, nsEventStatus * 0x0012f7b0, int & 1) line 782
nsView::HandleEvent(nsView * const 0x05efa6e0, nsGUIEvent * 0x0012f8c0, unsigned 
int 8, nsEventStatus * 0x0012f7b0, int & 1) line 755
nsView::HandleEvent(nsView * const 0x05ead480, nsGUIEvent * 0x0012f8c0, unsigned 
int 8, nsEventStatus * 0x0012f7b0, int & 1) line 755
nsView::HandleEvent(nsView * const 0x0593f900, nsGUIEvent * 0x0012f8c0, unsigned 
int 28, nsEventStatus * 0x0012f7b0, int & 1) line 755
nsViewManager2::DispatchEvent(nsViewManager2 * const 0x0593fae0, nsGUIEvent * 
0x0012f8c0, nsEventStatus * 0x0012f7b0) line 1369
HandleEvent(nsGUIEvent * 0x0012f8c0) line 69
nsWindow::DispatchEvent(nsWindow * const 0x05efa5b4, nsGUIEvent * 0x0012f8c0, 
nsEventStatus & nsEventStatus_eIgnore) line 560 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012f8c0) line 581
nsWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000 {x=??? 
y=???}) line 3673 + 21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 301, nsPoint * 0x00000000 {x=??? 
y=???}) line 3880
nsWindow::ProcessMessage(unsigned int 514, unsigned int 0, long 13697067, long * 
0x0012fc24) line 2785 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00410948, unsigned int 514, unsigned int 0, long 
13697067) line 829 + 27 bytes
(Assignee)

Comment 1

19 years ago

*** This bug has been marked as a duplicate of 38768 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 2

19 years ago
verif
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.