First use of "Old Charts" feature after call to ./collectstats.pl results in Software Error

RESOLVED INVALID

Status

()

Bugzilla
Reporting/Charting
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: Christian Schlotter, Assigned: gerv)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Bugzilla 3.0.2

see below

Reproducible: Always

Steps to Reproduce:
1. On the main page, click on "Reports".
2. On the next page, click on "Old Charts".
3. Next, click "Continue".
4. The following error message is displayed (see first attachment): "Software Error: Can't locate object method "png" via package "GD::Image" at /usr/lib/perl5/vendor_perl/5.8.8/Chart/Base.pm line 265."
5. Refresh page in your browser.
6. The correct page is displayed (see second attachment; the second attachment shows no graph because my Bugzilla installation does not have any bugs filed so far).
7. All subsequent uses of the "Old Charts" functionality (i.e. executing steps 1.-3. will result in step 6.)
8. Switch to Bugzilla's directory and run ./collectstats.pl.
9. Executing steps 1.-3. will result in the error message (step 4) again.
Actual Results:  
The first use of the "Old Charts" feature after running ./collectstats.pl produces an error message (step 4).

Expected Results:  
The first use of the "Old Charts" feature after running ./collectstats.pl should not produce an error message (like  in step step 6).

Software versions:
dev-lang/perl-5.8.8-r4
dev-db/mysql-5.0.54
sys-kernel/gentoo-sources-2.6.23-r6
media-libs/gd-2.0.35
www-apps/bugzilla-3.0.2
www-servers/lighttpd-1.4.18
(Reporter)

Comment 1

11 years ago
Created attachment 302804 [details]
Error message

Error message after first use of "Old Charts" feature after running ./collectstats.pl.
(Reporter)

Comment 2

11 years ago
Created attachment 302805 [details]
Correct display

Subsequent uses of the "Old Charts" feature result in the correct displaying of no graph because no bugs have been filed yet.
(Reporter)

Updated

11 years ago
Version: unspecified → 3.0.2

Comment 3

11 years ago
What happens if your installation has some bugs in it and you run collectstats.pl afterwards?
(Reporter)

Comment 4

11 years ago
I'm sorry. This was a problem on my end. I had to install dev-perl/GD in my linux distribution.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.