If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't change the "background-color" style of menuitems on Minefield3.04pre

RESOLVED INVALID

Status

()

Firefox
Menus
RESOLVED INVALID
10 years ago
8 years ago

People

(Reporter: Nimrod Bar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021104 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021104 Minefield/3.0b4pre

<?xml version="1.0"?>
<?xml-stylesheet href="chrome://global/skin/" type="text/css"?>

<dialog class="dialog"
	xmlns="http://www.mozilla.org/keymaster/gatekeeper/there.is.only.xul">
<toolbox>
  <menubar>
    <menu label="Menu">
        <menupopup>
            <menuitem label="Menuitem" style="background-color: red;"/>
        </menupopup>
    </menu>
  </menubar>
</toolbox>
</dialog>

style="background-color: red;" has no effect on the menuitem background color
It works perfectly on Firefox 2.0

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
I think you also need to set -moz-appearance to none. -moz-appearance overrides background and border settings. This is by design.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.