Closed Bug 417095 Opened 12 years ago Closed 12 years ago

Firefox 3 id spellchecker extension files

Categories

(Mozilla Localizations :: id / Indonesian, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: romihardiyanto, Unassigned)

References

Details

Attachments

(1 file)

119.33 KB, application/octet-stream
Pike
: review+
Details
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; id; rv:1.9b4pre) Gecko/2008021010 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; id; rv:1.9b4pre) Gecko/2008021010 Minefield/3.0b4pre

Following what missing when Axel landed on bug 320664 comment 15

The creator of the spellchecker dictionaries for Indonesian language is willing to tri-license the dictionary files according to http://www.mozilla.org/MPL/license-policy.html.

Will attach the dictionaries in a moment.

Reproducible: Always

Steps to Reproduce:
1. Checkout browser from CVS with MOZ_CO_LOCALE=id
2. Build and Run
Actual Results:  
Spellchecker for Indonesian language is missing

Expected Results:  
Spellchecker for Indonesian language included in distribution
The README_permission.txt contains email conversation from me with the creator of Indonesian dictionaries. It is stated that the creator is willing to relicense his work to be compatible Mozilla's tri-license.

README_id_ID.txt comes from original distribution of dictionary files.

The mozilla_words.diff contains diff with original dictionaries, following en-US with some other additions.
Attachment #302913 - Flags: review?(l10n)
Blocks: fx3-l10n-id
The best way to do this is to have this done is to add an entry for Indonesian to http://wiki.mozilla.org/L10n:Dictionaries and to point to a reference for the origin and license of the dictionary files.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Can I commit this?

I don't think we have any license issues anymore (the author grants Mozilla trilicensing system: README_permissions.txt)

And looks like this is a must have feature according to AMO stats:
https://addons.mozilla.org/id/firefox/statistics/addon/6293
Comment on attachment 302913 [details]
Dictionary files for Fx3-id

Hit'em. Please land the dictionary files in l10n/id/extensions/spellcheck/hunspell/, and add the license that Benitius Brevoort sent as a textfile next to it.

Please reference this bug in your check-in comment, something like "bug 417095, adding Indonesian dictionary. Original author is Benitius Brevoort <benitius.brevoort@kapusin.org>, relicensed by him for inclusion to MPL/GPL/LGPL, r=l10n@mozilla.com"
Attachment #302913 - Flags: review?(l10n) → review+
(In reply to comment #5)

Done (added file is README_licenses.txt)

RCS file: /l10n/l10n/id/extensions/spellcheck/hunspell/README_id_ID.txt,v
done
Checking in README_id_ID.txt;
/l10n/l10n/id/extensions/spellcheck/hunspell/README_id_ID.txt,v  <--  README_id_ID.txt
initial revision: 1.1
done
RCS file: /l10n/l10n/id/extensions/spellcheck/hunspell/README_licenses.txt,v
done
Checking in README_licenses.txt;
/l10n/l10n/id/extensions/spellcheck/hunspell/README_licenses.txt,v  <--  README_licenses.txt
initial revision: 1.1
done
RCS file: /l10n/l10n/id/extensions/spellcheck/hunspell/README_permissions.txt,v
done
Checking in README_permissions.txt;
/l10n/l10n/id/extensions/spellcheck/hunspell/README_permissions.txt,v  <--  README_permissions.txt
initial revision: 1.1
done
RCS file: /l10n/l10n/id/extensions/spellcheck/hunspell/id.aff,v
done
Checking in id.aff;
/l10n/l10n/id/extensions/spellcheck/hunspell/id.aff,v  <--  id.aff
initial revision: 1.1
done
RCS file: /l10n/l10n/id/extensions/spellcheck/hunspell/id.dic,v
done
Checking in id.dic;
/l10n/l10n/id/extensions/spellcheck/hunspell/id.dic,v  <--  id.dic
initial revision: 1.1
done
RCS file: /l10n/l10n/id/extensions/spellcheck/hunspell/mozilla_words.diff,v
done
Checking in mozilla_words.diff;
/l10n/l10n/id/extensions/spellcheck/hunspell/mozilla_words.diff,v  <--  mozilla_words.diff
initial revision: 1.1
done

Hooraay!
Hi Romi, I just updated your bugzilla priviledges so that you can now make bugs FIXED and VERIFIED.

As I saw this landing and getting picked up by tinderbox, marking FIXED. It might be a good idea to mark this bug VERIFIED when you tested this in a live build from ftp.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Thanks Axel,

Verified on tinderbox build: Mozilla/5.0 (Windows; U; Windows NT 5.1; id; rv:1.9pre) Gecko/2008040504 Minefield/3.0pre
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.