Location Bar is uneditable in popup windows

RESOLVED INVALID

Status

()

Firefox
Address Bar
RESOLVED INVALID
10 years ago
4 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; es-ES; rv:1.9b4pre) Gecko/2008021204 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; es-ES; rv:1.9b4pre) Gecko/2008021204 Minefield/3.0b4pre

The location bar cannot be edited in sites that launch popup windows.   You can launch new tabs, bookmarks, other functionality, but editing the Location bar does not seem to work.

Reproducible: Always

Steps to Reproduce:
1. Install nightly build
2. Find a site with a popup window  (eg. http://www.marketwatch.com or http://msnbc.com and launch something with video)
3. Verify in popup window, location bar is uneditable.  However, can open a new tab using keystroke, but cant enter in an address.
Actual Results:  
Location bar uneditable in a popup window

Expected Results:  
Location bar editable in a popup window
Whiteboard: DUPME
Whiteboard: DUPME → DUPEME
Bug 406222?
(In reply to comment #1)
> Bug 406222?

No. This is an old issue that Neil tried to fix but backed out due to regressions.
This is intentional, and has happened since bug 22183 landed if you had the dom.disable_window_open_feature.location pref set to true. The only thing that's changed between Firefox 2 and 3 is that we enabled that pref by default in bug 337344.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INVALID

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.