Clicking the Star should file to the Bookmarks Menu

RESOLVED DUPLICATE of bug 428524

Status

()

Firefox
Bookmarks & History
RESOLVED DUPLICATE of bug 428524
10 years ago
8 years ago

People

(Reporter: hhh, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX? #c1)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021204 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021204 Minefield/3.0b4pre

the Awesome Bar's star currently default to Unfiled Bookmarks. Unfiled Bookmarks? Come one, Fx, it's been a long day and I'm tired, file that foe me, would you? Like, maybe, to the Bookmarks Menu, where I'd expect it ti be?

Reproducible: Always

Steps to Reproduce:
1.
2.
3.



Ever since Places came aboard.
(Reporter)

Updated

10 years ago
Hardware: PC → All
Version: unspecified → Trunk
The intended behavior of the star is to have it always show up in your history, regardless of how often you visit it.  It's not meant to be a quick bookmark button...
Whiteboard: WONTFIX? #c1
(Reporter)

Comment 2

10 years ago
(In reply to comment #1)
> The intended behavior of the star is to have it always show up in your history,
> regardless of how often you visit it.  It's not meant to be a quick bookmark
> button...
> 
http://developer.mozilla.org/en/docs/Firefox_3_for_developers

"Star button. The new star button in the location bar lets you quickly add a new bookmark with a single click. A second click lets you file and tag your new bookmark."

So, yes a quick bookmark button. Going to an Unmarked file that the user has to navigate to 'Bookmarks>Show All Bookmarks...' to find.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021204 Minefield/3.0b4pre
(In reply to comment #1)
> The intended behavior of the star is to have it always show up in your history,
> regardless of how often you visit it.  It's not meant to be a quick bookmark
> button...
> 
And yet, the tooltip for the star says "Bookmark this page". 

There's no logical reason why those bookmarks should be less easy to access than other bookmarks.
(In reply to comment #3)
> And yet, the tooltip for the star says "Bookmark this page". 
And that's exactly what's happening.  It *is* being bookmarked, but not how *you* want it to be bookmarked.
for me is this 'unfiled bookmark' thingy totally useless and so is the actual behavior of star button
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All

Comment 6

10 years ago
You're both righ; the star is for bookmarking and to help create a db to improve awesomebar searching. 

However, this should be marked won't fix.  We don't want star created bookmarks going anywhere that most people prefer to keep highly organized, ie. bookmark menu, bookmark toolbar.  

Finding the single click star bookmark (in Unfiled Bookmarks) is not as complicated as going to the Library. Just click the star while visiting the bookmarked page.  If you've browsed away from the page and can't remember the exact url, use the awesomebar to search for it. Oh, hey, it's starred! thus helping to move it up the search list priority.

xtc4uall, do you find google totally useless?
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
(In reply to comment #6)
   
> Finding the single click star bookmark (in Unfiled Bookmarks) is not as
> complicated as going to the Library. Just click the star while visiting the
> bookmarked page.  If you've browsed away from the page and can't remember the
> exact url, use the awesomebar to search for it. Oh, hey, it's starred! thus
> helping to move it up the search list priority.
>
All of which is sure to create great confusion and frustration in many users until they get used to it. It would be much more intuitive if the Unfiled Bookmarks folder appeared in the Bookmarks dropdown, the extra step of clicking "Show All Bookmarks" is just pointless.

Having to navigate back to the page to edit the bookmark isn't exactly convenient, either. The use of this feature should be as convenient and discoverable as possible.

Comment 8

10 years ago
 It would be much more intuitive if the Unfiled
> Bookmarks folder appeared in the Bookmarks dropdown, the extra step of clicking
> "Show All Bookmarks" is just pointless.
> 

I think there is/was a bug for requesting that to appear on the menu.  
side note: "Unfiled Bookmarks" is most likely not going to be the final name of that folder.

[to clear up any confusion reposting from dev.apps.firefox]

Starring is the same thing as bookmarking, and we've tried very hard to continue to reinforce this with the language used throughout the UI:

-tooltip on the star says "Bookmark the page" / "Edit this bookmark"
-clicking on the star produces the message "Page Bookmarked"
-the page is placed in the folder "Unfiled Bookmarks" (unless you move it)
-to view the list of pages bookmarked by clicking the star you go to "Bookmarks" > "Show All Bookmarks..."

The image of the star is also used consitesntly as a metaphor for all bookmarks, for instance the toolbar icon to display the bookmarks sidebar is a book with a star embossed on the cover.  The backup bookmarks icon in the library window will also contain a star.

So I would like to continue to encourage everyone (especially anyone writing help or documentation) not to use the word star as an action verb.  On the flip side, any bookmark icons are going to use the image of a star as a visual metaphor.

If starring DOES make a bookmark, then it really should appear in
the normal Bookmarks menu imo

Here is our rationale for hiding unfiled bookmarks behind the menu item "Show All Bookmarks"

-Hitting the star is easy (by design), so users may end up with 2000 or 3000
unfiled bookmarks.  This is great in terms of searching against the places
database, but obviously can't scale to a browse-based UI like a folder on the
bookmarks toolbar, both in terms of usability and literally populating it with
that many items.

-If users see a huge list of bookmarks growing they may feel like they need to
manage the mess, instead of just searching against it.  If they do take a bunch
of time to file away all of the unfiled bookmarks, they may think to themselves
"that took forever and wasn't very fun, I need to bookmark less pages so I
don't have a such a queue of unorganized stuff in the future."  If that feeling
results in the user bookmarking fewer pages, than we have defeated the original
goal of making bookmarking light weight, easy, and faster than just searching
google for what you are looking for (which is what most people do instead of
bookmarking pages).

Comment 10

10 years ago
Crazy idea: don't show *any* bookmarks in the bookmarks menu.  Instead, show a search widget, similar to Help menus in Leopard.
As it is now, users have no idea where their unfiled bookmarks went - take a look at this help forum thread: 
 http://forums.mozillazine.org/viewtopic.php?t=629858&highlight=

Comment 12

10 years ago
See also bug 405487, "add a static 'Unfiled Bookmarks' item to the bookmarks menu", which is also WONTFIX.

Updated

10 years ago
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 428524
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.