Firefox crash while renaming Smart Bookmarks folder in the toolbar

VERIFIED WORKSFORME

Status

()

--
critical
VERIFIED WORKSFORME
11 years ago
10 years ago

People

(Reporter: fork0, Unassigned)

Tracking

({crash})

Trunk
x86
Windows 2000
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

just tried to rename the folder (into "Smarties") and it crashed.
Don't think it is relevant though, as the folder was found renamed
after the browser was restarted and an attempt to rename the folder again
did not crash anything.

Reproducible: Couldn't Reproduce

Steps to Reproduce:
1. rename "Smart Bookmarks" while on www.rtl.de through right-mouse/Properties in the toolbar

Actual Results:  
crash

Expected Results:  
no crash

WinDbg's crude stack strace:


Microsoft (R) Windows Debugger  Version 6.4.0007.2
Copyright (c) Microsoft Corporation. All rights reserved.

*** wait with pending attach
Symbol search path is: *** Invalid ***
****************************************************************************
* Symbol loading may be unreliable without a symbol search path.           *
* Use .symfix to have the debugger choose a symbol path.                   *
* After setting your symbol path, use .reload to refresh symbol locations. *
****************************************************************************
Executable search path is: 
ModLoad: 00400000 0044b000   D:\Programs\Firefox3\firefox.exe
ModLoad: 77f80000 77ffc000   C:\WINNT\system32\ntdll.dll
ModLoad: 603e0000 60c4f000   D:\Programs\Firefox3\xul.dll
ModLoad: 60160000 601c7000   D:\Programs\Firefox3\sqlite3.dll
ModLoad: 7c570000 7c623000   C:\WINNT\system32\KERNEL32.dll
ModLoad: 78130000 781cb000   D:\Programs\Firefox3\MSVCR80.dll
ModLoad: 78000000 78045000   C:\WINNT\system32\msvcrt.dll
ModLoad: 60050000 600dd000   D:\Programs\Firefox3\js3250.dll
ModLoad: 60000000 60030000   D:\Programs\Firefox3\nspr4.dll
ModLoad: 7c2d0000 7c335000   C:\WINNT\system32\ADVAPI32.dll
ModLoad: 77d30000 77da8000   C:\WINNT\system32\RPCRT4.dll
ModLoad: 75050000 75058000   C:\WINNT\system32\WSOCK32.dll
ModLoad: 75030000 75044000   C:\WINNT\system32\WS2_32.DLL
ModLoad: 75020000 75028000   C:\WINNT\system32\WS2HELP.DLL
ModLoad: 77570000 775a0000   C:\WINNT\system32\WINMM.dll
ModLoad: 77e10000 77e6f000   C:\WINNT\system32\USER32.DLL
ModLoad: 77f40000 77f7c000   C:\WINNT\system32\GDI32.dll
ModLoad: 60380000 60398000   D:\Programs\Firefox3\smime3.dll
ModLoad: 60290000 60336000   D:\Programs\Firefox3\nss3.dll
ModLoad: 60340000 60354000   D:\Programs\Firefox3\nssutil3.dll
ModLoad: 60040000 60047000   D:\Programs\Firefox3\plc4.dll
ModLoad: 60030000 60037000   D:\Programs\Firefox3\plds4.dll
ModLoad: 60360000 6037e000   D:\Programs\Firefox3\ssl3.dll
ModLoad: 7cf30000 7d186000   C:\WINNT\system32\SHELL32.dll
ModLoad: 71710000 71794000   C:\WINNT\system32\COMCTL32.dll
ModLoad: 70a70000 70ad5000   C:\WINNT\system32\SHLWAPI.dll
ModLoad: 7ce20000 7cf21000   C:\WINNT\system32\ole32.dll
ModLoad: 77820000 77827000   C:\WINNT\system32\VERSION.dll
ModLoad: 759b0000 759b6000   C:\WINNT\system32\LZ32.DLL
ModLoad: 77800000 7781e000   C:\WINNT\system32\WINSPOOL.DRV
ModLoad: 76620000 76630000   C:\WINNT\system32\MPR.DLL
ModLoad: 76b30000 76b6e000   C:\WINNT\system32\COMDLG32.dll
ModLoad: 75e60000 75e7a000   C:\WINNT\system32\IMM32.dll
ModLoad: 6b2c0000 6b2c5000   C:\WINNT\system32\MSIMG32.dll
ModLoad: 66650000 666a4000   C:\WINNT\system32\USP10.dll
ModLoad: 7c420000 7c4a7000   D:\Programs\Firefox3\MSVCP80.dll
ModLoad: 779b0000 77a4b000   C:\WINNT\system32\OLEAUT32.dll
ModLoad: 60c50000 60c57000   D:\Programs\Firefox3\xpcom.dll
ModLoad: 6ca60000 6ca68000   C:\WINNT\system32\LPK.DLL
ModLoad: 641f0000 641fc000   C:\PROGRA~1\NetInst\NiAMH.dll
ModLoad: 72a00000 72a2d000   C:\WINNT\system32\dbghelp.dll
ModLoad: 63000000 63014000   C:\WINNT\system32\SynTPFcs.dll
ModLoad: 01280000 012c5000   C:\WINNT\system32\MSCTF.dll
ModLoad: 775a0000 77630000   C:\WINNT\system32\CLBCATQ.DLL
ModLoad: 77840000 7787e000   C:\WINNT\system32\cscui.dll
ModLoad: 770c0000 770e3000   C:\WINNT\system32\CSCDLL.DLL
ModLoad: 600e0000 600f4000   D:\Programs\Firefox3\components\browserdirprovider.dll
ModLoad: 60100000 6013e000   D:\Programs\Firefox3\components\brwsrcmp.dll
ModLoad: 74fd0000 74fee000   C:\WINNT\system32\msafd.dll
ModLoad: 75010000 75017000   C:\WINNT\System32\wshtcpip.dll
ModLoad: 77340000 77353000   C:\WINNT\system32\iphlpapi.dll
ModLoad: 77520000 77525000   C:\WINNT\system32\ICMP.DLL
ModLoad: 77320000 77337000   C:\WINNT\system32\MPRAPI.DLL
ModLoad: 75150000 75160000   C:\WINNT\system32\SAMLIB.DLL
ModLoad: 7cdc0000 7ce10000   C:\WINNT\system32\NETAPI32.DLL
ModLoad: 7c340000 7c34f000   C:\WINNT\system32\Secur32.dll
ModLoad: 77bf0000 77c01000   C:\WINNT\system32\NTDSAPI.dll
ModLoad: 77980000 779a4000   C:\WINNT\system32\DNSAPI.DLL
ModLoad: 77950000 7797b000   C:\WINNT\system32\WLDAP32.DLL
ModLoad: 751c0000 751c6000   C:\WINNT\system32\NETRAP.dll
ModLoad: 773b0000 773df000   C:\WINNT\system32\ACTIVEDS.DLL
ModLoad: 77380000 773a3000   C:\WINNT\system32\ADSLDPC.DLL
ModLoad: 77830000 7783e000   C:\WINNT\system32\RTUTILS.DLL
ModLoad: 77880000 7790e000   C:\WINNT\system32\SETUPAPI.DLL
ModLoad: 7c0f0000 7c154000   C:\WINNT\system32\USERENV.DLL
ModLoad: 774e0000 77514000   C:\WINNT\system32\RASAPI32.DLL
ModLoad: 774c0000 774d1000   C:\WINNT\system32\rasman.dll
ModLoad: 77530000 77552000   C:\WINNT\system32\TAPI32.dll
ModLoad: 77360000 77379000   C:\WINNT\system32\DHCPCSVC.DLL
ModLoad: 782c0000 782cc000   C:\WINNT\System32\rnr20.dll
ModLoad: 777e0000 777e8000   C:\WINNT\System32\winrnr.dll
ModLoad: 66210000 66219000   C:\WINNT\system32\netware\NWWS2NDS.DLL
ModLoad: 50d50000 50d97000   C:\WINNT\system32\NETWIN32.DLL
ModLoad: 50d00000 50d15000   C:\WINNT\system32\CLNWIN32.DLL
ModLoad: 50df0000 50e10000   C:\WINNT\system32\LOCWIN32.DLL
ModLoad: 50db0000 50ddb000   C:\WINNT\system32\NCPWIN32.dll
ModLoad: 66220000 6622c000   C:\WINNT\system32\netware\NWWS2SLP.DLL
ModLoad: 1c000000 1c007000   C:\WINNT\system32\NWSRVLOC.dll
ModLoad: 60240000 60264000   D:\Programs\Firefox3\softokn3.dll
ModLoad: 60270000 60288000   D:\Programs\Firefox3\nssdbm3.dll
ModLoad: 603a0000 603d9000   D:\Programs\Firefox3\freebl3.dll
ModLoad: 7ca00000 7ca23000   C:\WINNT\system32\rsaenh.dll
ModLoad: 7c740000 7c7cc000   C:\WINNT\system32\CRYPT32.dll
ModLoad: 77430000 77440000   C:\WINNT\system32\MSASN1.dll
ModLoad: 601f0000 60234000   D:\Programs\Firefox3\nssckbi.dll
ModLoad: 777f0000 777f5000   C:\WINNT\system32\rasadhlp.dll
ModLoad: 70440000 704cf000   C:\WINNT\system32\mlang.dll
ModLoad: 77560000 77568000   C:\WINNT\system32\wdmaud.drv
ModLoad: 77400000 77408000   C:\WINNT\system32\msacm32.drv
ModLoad: 77410000 77423000   C:\WINNT\system32\MSACM32.dll
ModLoad: 0b860000 0b888000   C:\WINNT\system32\schannel.dll
ModLoad: 30000000 302ca000   C:\WINNT\system32\Macromed\Flash\NPSWF32.dll
ModLoad: 0c3f0000 0c486000   C:\WINNT\system32\WININET.dll
ModLoad: 69000000 6900e000   C:\WINNT\system32\Macromed\Common\SwSupport.dll
ModLoad: 6b770000 6b783000   C:\WINNT\system32\mscms.dll
ModLoad: 6e9d0000 6ea0f000   C:\WINNT\system32\icm32.dll
(b10.a00): Access violation - code c0000005 (!!! second chance !!!)
eax=00310031 ebx=04f44618 ecx=021543e8 edx=00000000 esi=00000008 edi=021543e8
eip=60878aa9 esp=0012b7e0 ebp=0012b820 iopl=0         nv up ei pl nz na pe nc
cs=001b  ss=0023  ds=0023  es=0023  fs=0038  gs=0000             efl=00000202
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programs\Firefox3\xul.dll - 
xul!JSD_GetValueWrappedJSVal+0x74e7:
60878aa9 8b4004           mov     eax,[eax+0x4]     ds:0023:00310035=????????
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for D:\Programs\Firefox3\js3250.dll - 


0:000> kv 400
ChildEBP RetAddr  Args to Child              
WARNING: Stack unwind information not available. Following frames may be wrong.
0012b820 608611d5 04c76aa4 00000055 00000000 xul!JSD_GetValueWrappedJSVal+0x74e7
0012b874 60962742 01f8cd28 00000055 00000000 xul!gfxImageSurface::Data+0x23792
0012b890 60405236 01f8cd28 00000016 00000002 xul!NS_InvokeByIndex_P+0x27
0012ba5c 60409148 00000000 052a24c0 00000000 xul!gfxPattern::CairoPattern+0x101ca
0012bb24 6007bcb3 059c9d48 046d0a80 00000002 xul!gfxPattern::CairoPattern+0x140dc
0012bbe8 60082030 059c9d48 00000002 052a24b0 js3250!js_Invoke+0x4c3
0012bd54 6007bcfb 059c9d48 0182bbbc 0012bd98 js3250!js_Invoke+0x6840
0012be10 60413f39 059c9d48 00000000 052a2498 js3250!js_Invoke+0x50b
0012bf9c 60416dc8 05adaa30 05977048 00000003 xul!gfxPattern::CairoPattern+0x1eecd
0012c068 60962894 04d6ccb0 00000003 0012c090 xul!gfxPattern::CairoPattern+0x21d5c
0012c084 60962742 04d6ccb0 0012c25c 60405236 xul!NS_InvokeByIndex_P+0x179
0012c090 60405236 04d6ccb0 00000003 00000000 xul!NS_InvokeByIndex_P+0x27
0012c25c 60409148 00000000 052a2490 00000000 xul!gfxPattern::CairoPattern+0x101ca
0012c324 6007bcb3 059c9d48 046d0640 00000000 xul!gfxPattern::CairoPattern+0x140dc
0012c3e8 60082030 059c9d48 00000000 052a2488 js3250!js_Invoke+0x4c3
0012c55c 6007bcfb 059c9d48 01830a28 0012c5a0 js3250!js_Invoke+0x6840
0012c618 60413f39 059c9d48 00000000 052a23dc js3250!js_Invoke+0x50b
0012c7a0 60416dc8 05adaa30 05c0f6e8 00000003 xul!gfxPattern::CairoPattern+0x1eecd
0012c86c 60962894 03393990 00000003 0012c894 xul!gfxPattern::CairoPattern+0x21d5c
0012c888 607d036f 03393990 607cfd54 00000000 xul!NS_InvokeByIndex_P+0x179
0012c8a4 607cf067 031f0ad0 00000000 0012c8f8 xul!gfxFont::NotifyLineBreaksChanged+0x73408
0012c8bc 60962742 00000000 03393990 0012cac0 xul!gfxFont::NotifyLineBreaksChanged+0x72100
0012c8d0 60405236 02d21688 00000003 00000001 xul!NS_InvokeByIndex_P+0x27
0012ca9c 60409148 00000000 052a23d4 00000000 xul!gfxPattern::CairoPattern+0x101ca
0012cb64 6007bcb3 059c9d48 03e20ec0 00000001 xul!gfxPattern::CairoPattern+0x140dc
0012cc28 60082030 059c9d48 00000001 052a23c8 js3250!js_Invoke+0x4c3
0012cd8c 6007bcfb 059c9d48 0182e1ac 0012cdd0 js3250!js_Invoke+0x6840
0012ce48 60413f39 059c9d48 00000001 052a23b0 js3250!js_Invoke+0x50b
0012cfd4 60416dc8 031ec368 0573f7c8 00000003 xul!gfxPattern::CairoPattern+0x1eecd
0012d0a0 60962894 031b0bf0 00000003 0012d0c8 xul!gfxPattern::CairoPattern+0x21d5c
0012d0bc 60962742 031b0bf0 03393990 0012d2c0 xul!NS_InvokeByIndex_P+0x179
0012d0d0 60405236 031b0bf0 00000003 00000001 xul!NS_InvokeByIndex_P+0x27
0012d29c 60409148 00000000 052a2394 00000000 xul!gfxPattern::CairoPattern+0x101ca
0012d364 6007bcb3 059c9d48 046d04c0 00000001 xul!gfxPattern::CairoPattern+0x140dc
0012d428 60082030 059c9d48 00000001 052a2388 js3250!js_Invoke+0x4c3
0012d5bc 6007bcfb 059c9d48 0581e494 0012d600 js3250!js_Invoke+0x6840
0012d678 6007be43 059c9d48 00000001 052a1fd4 js3250!js_Invoke+0x50b
0012d6a8 600573f7 059c9d48 04440400 046d0360 js3250!js_Invoke+0x653
0012d73c 605fed2d 04e42d20 04050160 046d0360 js3250!JS_CallFunctionValue+0x27
0012d858 606e4d6d 0188c9a0 033be210 033be200 xul!nsExpirationTracker<gfxFont,3>::CheckStartTimer+0xc5450
0012d9ec 60759126 04e42d20 04cc97d8 04cc97d8 xul!gfxContext::GetFlags+0x6217d
0012da20 604fd62d 030ebfe8 033be210 00000001 xul!gfxPlatform::GetFontList+0x1cd3
0012db18 604fd91f 030ebfe8 04e42d20 04e42d20 xul!gfxPDFSurface::GetDefaultContextFlags+0x44aa
0012db68 605e30b8 04c81808 04faa258 0012dda8 xul!gfxPDFSurface::GetDefaultContextFlags+0x479c
0012dba4 605e324f 00000202 02d170e0 0012ddc4 xul!nsExpirationTracker<gfxFont,3>::CheckStartTimer+0xa97db
0012dbc8 605e32bb 02d170e0 00000206 0012dca8 xul!nsExpirationTracker<gfxFont,3>::CheckStartTimer+0xa9972
0012dbf4 605e366b 02d170e0 00000006 0012dca8 xul!nsExpirationTracker<gfxFont,3>::CheckStartTimer+0xa99de
0012dc60 605204d7 0333ff80 04faa258 0012dda8 xul!nsExpirationTracker<gfxFont,3>::CheckStartTimer+0xa9d8e
0012dcb0 60520122 05971da0 0012dd2c 0012dda8 xul!gfxPDFSurface::GetDefaultContextFlags+0x27354
0012dcf8 60513c67 033535b4 05971da0 0012dda8 xul!gfxPDFSurface::GetDefaultContextFlags+0x26f9f
0012dd48 60601beb 04cf22f8 0012dda8 0012dd60 xul!gfxPDFSurface::GetDefaultContextFlags+0x1aae4
0012dd64 6088f385 0012dda8 059cc578 0012dda8 xul!nsExpirationTracker<gfxFont,3>::CheckStartTimer+0xc830e
0012dd8c 6089124b 00000000 1836759f 77e1a7f5 xul!gfxTextRun::GetFontGroup+0x38e8
0012de14 608916c3 00000083 00000000 0000000d xul!gfxTextRun::GetFontGroup+0x57ae
0012debc 6089272a 0000000d 001c0001 1836755b xul!gfxTextRun::GetFontGroup+0x5c26
0012e080 6088f7a9 00000100 0000000d 001c0001 xul!gfxTextRun::GetFontGroup+0x6c8d
0012e0bc 77e3a454 003b0236 00000100 0000000d xul!gfxTextRun::GetFontGroup+0x3d0c
0012e0dc 77e14605 6088f6e2 003b0236 00000100 USER32!SetWindowPlacement+0x4e
0012e168 77e1a7f2 0012e188 00000000 6089f8a5 USER32!TranslateMessageEx+0x605
0012e1a8 6089ee03 00000001 00000001 6089ef59 USER32!DispatchMessageW+0xb
0012e1d0 6091affa 00000001 0025c278 00000001 xul!gfxWindowsNativeDrawing::operator=+0x71be
0012e1fc 608fbbb3 0025c278 00000001 0012e210 xul!NS_GetComponentRegistrar_P+0xa1c
0012e214 607c9d08 0012e2d4 00000000 00000000 xul!NS_UTF16ToCString_P+0x207
0012e234 607cdfa8 01fc01b8 607ab82e 04f6a06c xul!gfxFont::NotifyLineBreaksChanged+0x6cda1
0012e458 607aa6e8 0174a3d0 057c00a8 00000000 xul!gfxFont::NotifyLineBreaksChanged+0x71041
0012e480 605fadd8 0174a3d4 0179e780 057c00a8 xul!gfxFont::NotifyLineBreaksChanged+0x4d781
0012e614 00000000 04e91dc8 05b022d8 600662f2 xul!nsExpirationTracker<gfxFont,3>::CheckStartTimer+0xc14fb

Comment 1

11 years ago
please read

http://developer.mozilla.org/en/docs/How_to_get_a_stacktrace_with_WinDbg

you need to set the symbol path. in the future, please only paste the kp output after you've set symbol path (the list of loaded libraries is useless, a stack trace without symbols is useless, as is the binary output from kvv)
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
> after you've set symbol path (the list of loaded libraries is useless, a stack
> trace without symbols is useless, as is the binary output from kvv)

Huh?! How about "I'm too lazy to go through the dump and resolve the addresses,
let users do that. And while they are at it they can as well download the symbols from the server, nevermind it is not the information they'll find
readily available, they can google it out. And it is no problem to download
60mb on a decent link".
Alex, wasn't the built-in Crash reporter fired when Firefox has crashed? Its output would be more helpful as the one you gave. Let's have a look at http://kb.mozillazine.org/Breakpad.

You could try to create a new profile and test again if it is reproducable. Thanks.
Version: unspecified → Trunk
Keywords: crash
(Reporter)

Comment 4

11 years ago
(In reply to comment #3)
> Alex, wasn't the built-in Crash reporter fired when Firefox has crashed? Its
> output would be more helpful as the one you gave. Let's have a look at
> http://kb.mozillazine.org/Breakpad.

It didn't run.

> You could try to create a new profile and test again if it is reproducable.

It is not.


As "Smart bookmarks" folder doesn't exists in newer builds, I think this bug can change its resolution to Wontfix.
Alex, please try again with a fresh profile and rename any default saved search folder e.g. Most Visited. Does the crash occur? If not, please mark this bug as WFM.
(Reporter)

Comment 7

10 years ago
Cannot reproduce.
Something like "Most Visited" cannot be renamed (no such an item in the context menu).
"Smart bookmarks" could be renamed  without any problem and the change was reflected in the menu and toolbar immediately (yes, my copy of 3.0b5 had "Smart bookmarks").

Marking the bug WFM, as it does.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
Thanks Alex. Marking as Verified because I'm also not able to reproduce the crash.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.