On exit, users are not prompted to save tabs on exit

RESOLVED WORKSFORME

Status

()

Firefox
Tabbed Browser
--
major
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Jechezkel Frank, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

Although the What's new page (http://www.mozilla.com/en-US/firefox/3.0b3/releasenotes/#whatsnew) says that there is a new tab features:

"Save what you were doing: Firefox will prompt users to save tabs on exit."

This does not happen. It does not even ask if I am sure to close all tabs if more than one tab is open.

This was not a problem in FF3B2, only since FF3B2.

Reproducible: Always

Steps to Reproduce:
1. Open multiple tabs
2. Click the Exit button
Actual Results:  
Firefox closes without prompting anything.

Expected Results:  
Prompt to save tabs or at least warn me, since multiple tabs are open, if I really want to close all tabs.
Reporter: This WFM using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3. If you accidentally checked the box that says "Do not ask next time" that might be it.  Another possibility is to go to Tools | Options and check the Main tab - if you have Firefox set to "Show My Windows and Tabs from Last time" you will not get the prompt when you exit Firefox.
Jechezkel: can you please comment back with the value of the preference(s) mentioned in comment 1, so we can determine if this is indeed a bug?  Thanks!
(Reporter)

Comment 3

10 years ago
Hi Stephen,
I have now restaged my machine with FF 2 since I had a few problems, one of them being FF3 freezing on me often. I assume it was the machine. Will however install FF3B3 again and give you feedback on this bug still today.
(Reporter)

Comment 4

10 years ago
Hi Stephen and Marcia, 
It looks like this bug is not a bug and probably more what Marcia said: I probably accidentally checked the check box "Do not ask next time".
Feel free to reject the bug.
Thanks,
Cheski

Comment 5

10 years ago
Resolving per comment #4.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.