Get Add-ons' See all results links cant search AMO

VERIFIED DUPLICATE of bug 414595

Status

()

VERIFIED DUPLICATE of bug 414595
11 years ago
10 years ago

People

(Reporter: an0n1m0us, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

"See all results (X)" link is broken due to URL encoding. Example:

A search for 

 Tab Mix Plus

is parsed to the AMO search engine as:

 Tab%20Mix%20Plus

and returns zero results.

Reproducible: Always

Steps to Reproduce:
1. Open Add-ons manager
2. Click to Get Add-ons
3. Search for any multi-word phrase
4. If results include incompatible add-ons, 'See all results (X)' link appears
Actual Results:  
1. Click "See all results (X)" link, AMO search loads with URL encoded search string and always returns zero results.

Expected Results:  
An AMO search without errors due to poorly formatted search string
(Reporter)

Updated

11 years ago
Blocks: 404024
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 414595
Verified dup
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.