List overlaps float, preventing clicking link in float

RESOLVED INVALID

Status

()

Core
Layout: Floats
RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: Jens Teubner, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.12) Gecko/20080207 Ubuntu/7.10 Firefox/2.0.0.12

If you visit

  http://www-db.in.tum.de/~teubnerj/firefox-bug/N113E0.html ,

The Acrobat PDF logo and the caption underneath it should both link to a PDF document (haven't uploaded the actual PDF at this URL).  Only the upper part of the image, however, is active as a link.  Page validates as XHTML Strict and renders properly on, e.g., Opera.  Depending on the specific system configuration and the actual HTML (I have many similar of them, automatically generated) the active region can be very hard to find in Firefox' rendering.

The logo and its caption are within a <div> environment with `float: right'.

Reproducible: Always
You can use the bookmarklet on this page http://slayeroffice.com/tools/modi/v2.0/modi_help.html to see what is going on. 

Updated

11 years ago
Component: Layout → Layout: Floats
QA Contact: layout → layout.floats
Summary: link not properly rendered (floating image and text) → List overlaps float, preventing clicking link in float

Comment 2

9 years ago
Thanks for reporting.

However, there is no bug. The list of authors is positioned above the floated element because it's relatively positioned.

I recommend removing the rel. pos. on the list, as the result is the same across all browsers (including IE8). I don't see another way of achieving your goal.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.