Locationbar autocomplete dropdown background is bright white when it should be gray

VERIFIED FIXED in Firefox 3 beta4

Status

()

--
trivial
VERIFIED FIXED
11 years ago
11 years ago

People

(Reporter: Aleksej, Assigned: dao)

Tracking

({regression})

Trunk
Firefox 3 beta4
x86
Linux
regression
Points:
---
Bug Flags:
blocking-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b4pre) Gecko/2008021304 Minefield/3.0b4pre

The background of the location bar autocomplete dropdown list is bright white (hurts eyes), though it was gray in 2008021204, and every other dropdown list was and is gray, in both Firefox and other GTK applications.

Using Xfce 4 with Raleigh colors on Debian GNU/Linux “lenny”.
Flags: blocking-firefox3?
I guess we should probably just restore the rule from bug 411289 comment 15. I'm not sure where that background color is defined, but it's apparently not http://lxr.mozilla.org/seamonkey/source/toolkit/themes/gnomestripe/global/autocomplete.css#83 ...
(Reporter)

Comment 2

11 years ago
Created attachment 303067 [details]
The old (top) vs the new (bottom) background color.
(Assignee)

Comment 3

11 years ago
It's -moz-appearance: menupopup; from gnomestripe's popup.css.
Summary: Locationbar autocomplete dropdown background is bright white when it should be gray. (non-native, color, integration) Since the 2008-02-13 nightly. → Locationbar autocomplete dropdown background is bright white when it should be gray. (non-native, color, integration) Since the 2008-02-13 nightly
Keywords: helpwanted
(Assignee)

Comment 4

11 years ago
Created attachment 303145 [details] [diff] [review]
make the richlistbox transparent again
Assignee: nobody → dao
Status: NEW → ASSIGNED
Attachment #303145 - Flags: review?(gavin.sharp)
(Assignee)

Updated

11 years ago
Severity: normal → trivial
Keywords: helpwanted → regression
Summary: Locationbar autocomplete dropdown background is bright white when it should be gray. (non-native, color, integration) Since the 2008-02-13 nightly → Locationbar autocomplete dropdown background is bright white when it should be gray
Attachment #303145 - Flags: review?(gavin.sharp) → review+
Attachment #303145 - Flags: approval1.9?
Comment on attachment 303145 [details] [diff] [review]
make the richlistbox transparent again

a=beltzner
Attachment #303145 - Flags: approval1.9? → approval1.9+
Keywords: checkin-needed
Checking in toolkit/themes/gnomestripe/global/autocomplete.css;
/cvsroot/mozilla/toolkit/themes/gnomestripe/global/autocomplete.css,v  <--  autocomplete.css
new revision: 1.17; previous revision: 1.16
done
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 beta4
(Reporter)

Comment 7

11 years ago
Verified fixed with Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.9b4pre) Gecko/2008021404 Minefield/3.0b4pre. Thanks.
Status: RESOLVED → VERIFIED
Flags: blocking-firefox3? → blocking-firefox3+
You need to log in before you can comment on or make changes to this bug.