Find dialog does not show up on view-source window.

VERIFIED FIXED

Status

SeaMonkey
UI Design
P3
major
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: Prashant Desale, Assigned: Bill Law)

Tracking

({helpwanted})

Trunk
x86
Windows 95
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

18 years ago
If we want to search for particular string in view-source window, its not 
possible because find dialog does not show up.

BUILDS: 2000-060508.

STEPS TO REPRODUCE:
1] Select Menu "Page Source" under menu "View".
2] It will open new window with page source. 
3] Use command CTRL+F [On windows] to get "find Dialog box".


EXPECTED RESULTS:
"Find Dialog box" should be generated in order to allow user to search for 
particular string.

ACTUAL RESULTS:
No "find Dialog box" appears.
*** Bug 42437 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
law should get this.
Assignee: ben → law

Comment 3

18 years ago
M20.  This is not a beta blocker.

Target Milestone: --- → M20

Comment 4

18 years ago
QA contact: sariuh@netscape.com -> sairuh@netscape.com
QA Contact: sariuh → sairuh
(Reporter)

Comment 5

18 years ago
nominating for nsbeta3 coz I feel we should not keep this without being able to 
search for keyword in HTML source.
Keywords: nsbeta3

Comment 6

18 years ago
Nav triage team: [nsbeta3-]; "View Source is for tech weinies"
Whiteboard: [nsbeta3-]
and anyone who develops web pages. [sairuh pictures irritated web developers
getting even more fed up.] sigh.
Keywords: helpwanted
it's in communicator 4.7x too.
Keywords: 4xp

Comment 9

18 years ago
i agree wtih sairuh, it is a pretty usefull feature that is usually used a lot
Keywords: 4xp
(Reporter)

Comment 10

18 years ago
Cmon guys. We are talking about find dialog on view-source window.
Its very widely used thing. 
How are you going to find particular HTML tags or anything particular in huge 
source without find dialog.

Comment 11

18 years ago
Yes, the only people who deal with HTML source are tech weinies.  Wow, and 
there's billions of webpages out there -- that sure is a lot of tech weenies!

The product is nearly centered around web developers, with it's terrific 
standards compliance et al, so why the heck are we shipping a half-assed view 
source capability?  If bug 26593 isn't +'ed (and I say this with all honesty), 
we may as well remove the view source capability.  Altenatively, we can plus 
bug 8589 and be done with it.  It probably wouldn't be as hard as some might 
think (might not involve more than just opening the source in the user's 
default text\plain helper app).  The current implementation is a joke and an 
insult to developers.  Can't select some characters.  Can't copy from it.  No 
select all. No find capabilities.  Takes forever to load the source.  I find 
myself opening IE all the time to view source...NO, I don't want to take the 
time to save the webpage, open it up in notepad, do what I have to do, and 
delete the local webpage copy from my computer.  Neither does anyone else.

I'm not asking that this be plussed because I don't feel it's quite as 
important as 26593 (which MUST be plussed).  (Of course, I think this is 
important also, but if one had to be minused of the two, I'd want it to be this 
one).  I'm just saying that we need to get out of this whole 'only tech weenies 
use view source, so it's not important' mentality.  Only tech weenies use XML, 
CSS1/CSS2, XUL, XBL and DOM[0-2], but resources were devoted to them, were they 
not?

Also, please understand that I'm not just sitting around whining for this stuff 
to be fixed.  Be assured I will be looking at these view source issues as soon 
as I have some free time (juggling school, development and QA...oh and that 
whole 'life' thing..)

Comment 12

18 years ago
There was talk that vidur was going to change View Source to not use the funky 
XML thing (which also makes selection and copy hard), but to just dump out the 
text. Then Find would Just Work in this window. Vidur, what's happening there?
dunna why 4xp was removed, since it really is a feature in communicator 4.7x.
honest. :)
Keywords: 4xp
(Assignee)

Comment 14

18 years ago
You aren't.  But the time to have thought of that was at the time the function 
was removed.  We don't have time to go back and reimplement everything so it 
actually works.
hunh? it wasn't/isn't/shouldn't be 4xp?

Comment 16

18 years ago
vidur is going to convert view-source to output HTML, at which point making Find 
work is juset a small matter of XUL.
(Assignee)

Comment 17

18 years ago
Sorry, I was replying to Prashant's earlier comment, not yours.  It is truly 
4xp, just not tops on our list to fix.  It might actually be easy, if anybody 
understands how view-source works now and has time to look into it.
(Reporter)

Comment 18

18 years ago
Bill sure I do understand that we don't have time to go back and reimpliment 
everything so it actually works. 
Think of this way. Everybody would have to open IE if he wants to edit source 
and look for particular things, if we don't make this working. [So here we are 
expecting people to use our browser to view web pages but asking them to go to 
Microsoft IE if they want to play with HTML source.]
I strongly feel that either both this one as well as bug# 26593 should be fixed 
OR ATLEST bug# 8589 should be fixed.

Comment 19

18 years ago
Find and Copy (Ctrl-C) will NOT work until, as Simon mentioned earlier, the view
source window is reimplemented to not use anonymous/pseudo content. The find and
copy code cannot process any text that is not actually in the document's DOM tree.
That last thing sounds like a bug to me, is there a bug open on not being able
to search generated content? XML docs will be full of that...

Comment 21

18 years ago
Now that the source is no longer generated content, I believe the find dialog 
can be brought up on each platform (with each platform's respective find dialog 
accelerator).  Marking fixed, please reopen if I'm mistaken...
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
vrfy fixed on winnt/linux/mac [2000.09.18.05/6/8 opt comm].
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite

Updated

10 years ago
Component: XP Apps: GUI Features → UI Design
You need to log in before you can comment on or make changes to this bug.