Spellchecker breaks apostrophes in single line input box fields

RESOLVED DUPLICATE of bug 422982

Status

()

RESOLVED DUPLICATE of bug 422982
11 years ago
10 years ago

People

(Reporter: Portfolioso, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

When spell checking any field after the user sets layout.spellcheckDefault to 2 in about:config, letters after an apostrophe are not included as the same word.

For example if the word "didn't" is typed, Firefox will highlight "didn" and say it is not in the dictionary. The "t" will be regarded as a separate word.

This does not happen when layout.spellcheckDefault is set to 1.

Reproducible: Always

Steps to Reproduce:
1. In about:config, set layout.spellcheckDefault to 2
2. In any text field, type in words with apostrophes
3. The word will not be in the dictionary
Actual Results:  
For example if the word "didn't" is typed, Firefox will highlight "didn" and say it is not in the dictionary. The "t" will be regarded as a separate word.

Expected Results:  
A word with an apostrophe should be spellchecked properly
(Reporter)

Comment 1

11 years ago
One other thing, when enter is pressed and a new line is invoked, the word is un-highlighted, but if you remain on the same line without pressing enter - it will remain underlined.

This happened in a textbox using moodle (a php course management system).

Comment 2

10 years ago
I can confirm this bug in several Mozilla applications on Windows Vista Home Premium. I've tested:

Firefox 3.0.3
Seamonkey 2.0a1
Thunderbird 3.0a3

both with Italian and English dictionary.

Previous applications based on the Myspell component like Thunderbird 2.0.17 are OK, while the new ones based on Huspell have this issue.

However, in my case setting layout.spellcheckDefault to 1 doesn't resolve anything.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422982
You need to log in before you can comment on or make changes to this bug.