Closed Bug 417425 Opened 17 years ago Closed 16 years ago

Pref to disable bookmark search in location bar

Categories

(Firefox :: Address Bar, enhancement)

enhancement
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 424557

People

(Reporter: scrtyfrk, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

Find a way to disable the auto-complete of the new location bar ("Awesome Bar").  Setting browser.urlbar.richResults to false (now defunct) or an associated extension to disable the new location bar search only gets rid of the formatting and not the search functionality.  This should possibly be an option added to the Privacy tab under the Options dialog.

Reproducible: Always

Steps to Reproduce:
1.Bookmark some different pages
2.Disable new Location Bar feature using oldbar.xpi extension
3.Restart browser
4.Type something into Location Bar
Actual Results:  
Auto-complete results still show pages from the bookmarks folder

Expected Results:  
Location Bar auto-complete should show only what is saved in the browsing history (FF2 functionality) or if browsing history cleared, should show nothing.

Having the auto-complete show results from the bookmarks folder could lead to privacy concerns if private bookmarks are shown by default at inappropriate times.  Having to rely on an external extension to disable this is not an appropriate response to this potential privacy issue.  If privacy deserves a tab under the options dialog, disabling this feature deserves a solution in such tab.
Summary: Disable Bookmark folder search auto-complete for location bar → Pref to disable bookmark search in location bar
Is that what that is?  I was trying to get a family member interested in Firefox 3 Beta 5 this morning and we soon hit this problem when the Location Bar shows stuff when she cleared her Private Data.  She uninstalled Firefox 3 quicker than Speedy Gonzales.  =(

Please fix this bug!  (Yes, this is a bug!  Not an enhancement request!)  I believe it to be critical as well!  If this doesn't get fixed, people are going to boycott Firefox 3 in favor of staying with 2 or they'll jump ship to Opera or Safari!
I totally agree that this should be considered as not only a bug but also as something that will prevent users from switching to Firefox 3. I downloaded Firefox 3 beta and started using it while my kids were watching over my shoulder. I was in for a big surprise when the auto-complete feature started showing some of my bookmarks that I never wanted anybody to see especially my kids. I can't use Firefox 3 unless there is an option to turn off searching bookmarks while using auto-complete. If this is not fixed immediately  Firefox 3's acceptance will be severely hampered. But I do like the auto-complete feature very much as long as there is an option in the privacy tab of options to turn off the search of bookmarks.
https://addons.mozilla.org/en-US/firefox/addon/7429

Apparently Ed made an extension that stops bookmarks from being searched and regulates the AwesomeBar to searching history only.

So I guess this and the other similar type bugs on AMO can be closed because it's by intent that the AwesomeBar searches Bookmarks by default and that there is now an extension that shuts off that function for people who don't want bookmarks searchable.
See also bug 395161 and bug 424557
OS: Windows Vista → All
Hardware: PC → All
Ngamer01:

I tried finding the addon you mention and could not find it even by following your link.  The closest was

https://addons.mozilla.org/en-US/firefox/addon/6227

Also, would like to say that I coded this as an enhancement because the feature works as it should.  It, however, has unintended consequences.  As a work around I found that changing property browser.urlbar.maxRichResults and setting it to 0, stops FF3 from displaying any results, which is the behavior I like since I don't keep any history.  As long as I have access to that, I don't mind having to change it once and forgetting about it.  

Thanks to Michael Warner for the inclusion of those two other bug reports.  I really don't think either one is as specific as this one because they ask for new functionality above and beyond what the awesomebar was originally intended to do.  Here it's simply asked that we be allowed to turn it off through an option in the preferences.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.