Command left arrow (back) does not work if a word has been highlighted on a page using find

RESOLVED INVALID

Status

()

Firefox
Keyboard Navigation
RESOLVED INVALID
11 years ago
9 years ago

People

(Reporter: Michael, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

Normally, to go back to the previous page, you can hit command-left.  This normally works fine.  But if I do a search for a word on a web page, and that word is highlighted, I then can not use command-left unless I click on the page again (causing the word to lose the highlight).

Reproducible: Always

Steps to Reproduce:
1.  Go to http://docs.info.apple.com/article.html?artnum=304901
2.  Hit command-F to bring up the search bar
3.  Type "surround" (you should see the word surround highlight in the box on optical digital audio.)
4.  Now try typing command-left to go back to the previous page.  Nothing happens.
5.  Click on the page, causing the word to no longer be highlighted.
6.  Now try typing command-left to go back to the previous page again.  You go back to the previous page
Actual Results:  
You don't go back to the previous page

Expected Results:  
You should go back to the previous page

I've also tried the same browser version on XP SP2.  The problem does not occur on that machine.

Comment 1

11 years ago
When a textbox has focus, Cmd+(left, right) moves to the (beginning, end) of the line.  The alternate back/forward shortcuts, Cmd+('[', ']'), should work regardless of focus.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID

Updated

9 years ago
Duplicate of this bug: 493472

Updated

9 years ago
Duplicate of this bug: 493472
You need to log in before you can comment on or make changes to this bug.