Scrollbars don't appear on resize with -moz-column-width

RESOLVED DUPLICATE of bug 389462

Status

()

Firefox
General
RESOLVED DUPLICATE of bug 389462
10 years ago
9 years ago

People

(Reporter: John P Baker, Unassigned)

Tracking

Trunk
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008021304 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9b4pre) Gecko/2008021304 Minefield/3.0b4pre

Display wrong if you resize a page containing columns so that it should gain scrollbars

Reproducible: Always

Steps to Reproduce:
1. Load testcase
2. resize window so (just) hasn't any scrollbars
3. resize window smaller (eg drag right edge of window in) so content won't fit on page
Actual Results:  
No scrollbars. Bottom content not displayed.

Expected Results:  
Scollbars. Proper display.
(Reporter)

Comment 1

10 years ago
Created attachment 303268 [details]
testcase
(Reporter)

Updated

10 years ago
Version: unspecified → Trunk
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021407 Minefield/3.0b4pre

I can't reproduce this. Can you explain step 2, in what way did you resize?
(Reporter)

Comment 3

10 years ago
Created attachment 303488 [details]
before resize
(Reporter)

Comment 4

10 years ago
Created attachment 303489 [details]
after resize

Window resized by dragging in right edge by about 50px - enough that it would need scrollbars
(Reporter)

Comment 6

10 years ago
Created attachment 304003 [details]
testcase

This is an automatic version of the testcase. The testcase is loaded into an IFRAME which is resized after 5 seconds.
(Reporter)

Comment 7

10 years ago
Created attachment 304004 [details]
reference for new testcase

Comment 8

10 years ago
Scrollbars don't appear because the content is no longer displayed. See bug 422089 which is a dup of this one, I guess

Comment 9

10 years ago
I can always reproduce maybe same problem on roc's blog too. for example: 
http://weblogs.mozillazine.org/roc/archives/2008/01/subpixel_layout.html

My step to reproduce is:
 1. opens the above URL.
 2. make the browser window narrow to display only two columns.
 3. maximize the browser window (by this, it should show three or more columns)
 4. restore the maximized browser window.

Comment 10

10 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9pre) Gecko/2008040404 Minefield/3.0pre

Reproducible on Mac with comment #6 testcase and comment #9 steps.

Comment 11

10 years ago
Thanks for reporting and mentioning this in Bug 422089 comment #2
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 422089
(Reporter)

Updated

9 years ago
Duplicate of bug: 389462
You need to log in before you can comment on or make changes to this bug.