Closed Bug 417497 Opened 13 years ago Closed 13 years ago

"Always show tab bar" taken too literally. Can't close window with command-W

Categories

(Firefox :: Tabbed Browser, defect)

PowerPC
macOS
defect
Not set
normal

Tracking

()

VERIFIED DUPLICATE of bug 348031

People

(Reporter: brkemper, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b3) Gecko/2008020511 Firefox/3.0b3

Command-W is the normal way to close windows on Mac OS. In FireFox (and Safari and probably others) it closes tabs first, and then the window when there is only one tab left. But in Firefox, if the preference is set to "Always show tab bar", then the window becomes unclose-able via the keyboard. The last page will disappear with command-W, but the window remains as a blank window, even if there is more than one window open. When there is only one tab left in a window (blank or not), pressing command-W SHOULD close the window, regardless of the tab setting.

Reproducible: Always

Steps to Reproduce:
1.Set prefs to "Always show tab bar"
2.Press command-W repeatedly

Actual Results:  
the window doesn't close

Expected Results:  
the window should close
Status: UNCONFIRMED → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 348031
Verified dup
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.