IRIs (URLs with IDN) not shown in suggestion menu of location bar

RESOLVED WORKSFORME

Status

()

Firefox
Address Bar
RESOLVED WORKSFORME
11 years ago
10 years ago

People

(Reporter: petr.pisar, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021304 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b4pre) Gecko/2008021304 Minefield/3.0b4pre

After typing part of IRI, IDN items in menu with suggested addresses are broken. Title line is printed, address line is empty, selecting affected item has no effect.

Reproducible: Always

Steps to Reproduce:
0.Options network.enableIDN and network.IDN.whitelist.<TLD> need's to be set to True.
1.Visit a web page utiliziting IDN
2.Visit another page
3.Focus address bar and type few letters from IRI or title of web from first step
Actual Results:  
Suggested items with IDN has no IRI printed, selecting such a item results in nothing.

Expected Results:  
All items, including the one with IDN, should print both title and IRI.
Slecting item with IDN should fill in addres bar with given IRI and navigate the broweser to it.

Options network.enableIDN and network.IDN.whitelist.<TLD> need's to be set to True. Otherwise punycode is shown properly. In other words, IDN in unicode form is not shown in the menu, punycode represention works.

This bug is regresion in Firefox 3. All nigtbuilds until unknow version worked correctly. Unkown means I can't remember when it got broken.

Comment 1

11 years ago
Mozilla/5.0 (X11; U; Linux i686 (x86_64); eo; rv:1.9b4pre) Gecko/2008022304 Minefield/3.0b4pre
For me, http://пример.испытание/ appears in autocomplete as http://?@8<5@.8A?KB0=85/ , and thus does not work.

May be related or a duplicate of bug 412457.
(Reporter)

Comment 2

11 years ago
It works now --- Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b5pre) Gecko/2008031604 Minefield/3.0b5pre again.

The only bug remaining is that it stops autocompleting after typing dot (domain delimiter).
(Reporter)

Comment 3

10 years ago
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9pre) Gecko/2008050104 Minefield/3.0pre

Bug seems fixed completely.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.