Release/News Announcement for 3.0.4, 3.1.4, 2.22.4, and 2.20.6

RESOLVED FIXED

Status

()

Bugzilla
bugzilla.org
--
blocker
RESOLVED FIXED
10 years ago
9 years ago

People

(Reporter: Emmanuel Seyman, Assigned: Max Kanat-Alexander)

Tracking

Details

Attachments

(2 attachments, 4 obsolete attachments)

(Reporter)

Description

10 years ago
 

Updated

9 years ago
Assignee: website → cedric.corazza

Comment 1

9 years ago
Created attachment 311248 [details] [diff] [review]
Patch for  News/announcement

Assuming that security bug 419188 also apply to 2.20 and 2.22 branches.
Attachment #311248 - Flags: review?(mkanat)

Comment 2

9 years ago
Comment on attachment 311248 [details] [diff] [review]
Patch for  News/announcement

No security release for 2.20 nor 2.22.
Attachment #311248 - Flags: review?(mkanat) → review-

Comment 3

9 years ago
Created attachment 311354 [details] [diff] [review]
Patch for Release/news v2
Attachment #311248 - Attachment is obsolete: true
Attachment #311354 - Flags: review?(LpSolit)

Comment 4

9 years ago
Comment on attachment 311354 [details] [diff] [review]
Patch for Release/news v2

A quick thing I've spotted:

>+<p><a href="../releases/3.0.4/">Bugzilla 3.0.4</a> is the last stable release
>+  of the 3.0.x series. In addition to various bug fixes, it also contains a security
>+  fix discovered in 3.0.x and 3.1.x series.</p>


last -> latest as last implies to me that there won't be any more?

Comment 5

9 years ago
Comment on attachment 311354 [details] [diff] [review]
Patch for Release/news v2

>+<p><a href="../releases/3.0.4/">Bugzilla 3.0.4</a> is the last stable release

As Colin said, "last" should be "latest".


>+  of the 3.0.x series. In addition to various bug fixes, it also contains a security
>+  fix discovered in 3.0.x and 3.1.x series.</p>

You should specify that 3.0.4 contains many fixes in email_in.pl (creating and editing bugs per email) and many additions to the documentation.


>+<p><a href="../releases/3.2/">Bugzilla 3.1.4</a> also contains the 
>+  security fix, but just like 3.1.3, it has had massive changes and 
>+  received little or no testing. It should be considered unstable and 
>+  only used in testing environments.</p>

3.1.4 has much less massive changes than 3.1.3, and got more bug fixes in order to prepare 3.2 RC1. It also received some testing and is more stable than previous 3.1.x releases, but it still shouldn't be used in production yet, though. One hot spot is searches based on strings in comments and in bug summaries which should now be much faster. And SMTP authentication is also supported for the very first time.


>+Read the <a href="../security/3.0.4/">Security Advisory</a> for more
>+details.</p>

The URL is incorrect. It will be "../security/3.0.3/".
Attachment #311354 - Flags: review?(LpSolit) → review-

Comment 6

9 years ago
Created attachment 311855 [details] [diff] [review]
Patch for Release/news v3

Patch addressing all the comments
Attachment #311354 - Attachment is obsolete: true
Attachment #311855 - Flags: review?(LpSolit)

Comment 7

9 years ago
Comment on attachment 311855 [details] [diff] [review]
Patch for Release/news v3

Looks good. r=LpSolit
Attachment #311855 - Flags: review?(LpSolit) → review+

Comment 8

9 years ago
Created attachment 317367 [details] [diff] [review]
Patch for Release/news v4

Fixes to add the 2.20.x and 2.22.x series
Attachment #311855 - Attachment is obsolete: true
Attachment #317367 - Flags: review?(LpSolit)

Comment 9

9 years ago
Comment on attachment 317367 [details] [diff] [review]
Patch for Release/news v4

>+<h3>3.1.4</h3>

>+  contains the security fix for 3.0.x series and another one specific to 3.1.x
>+  series.

This string should be reworded. 3.1.4 has 3 security fixes, 3.0.4 has 2, and 2.20.6 and 2.22.4 both have only one. Also, you should add a section for 2.20.6 and 2.22.4 (a single section for both).
Attachment #317367 - Flags: review?(LpSolit) → review-

Comment 10

9 years ago
Created attachment 319032 [details] [diff] [review]
Patch for News v5

This one addresses latest LpSolit comments
Attachment #317367 - Attachment is obsolete: true
Attachment #319032 - Flags: review?(LpSolit)
(Assignee)

Updated

9 years ago
Summary: Release/News Announcement for 3.0.4 and 3.1.4 → Release/News Announcement for 3.0.4, 3.1.4, 2.22.4, and 2.20.6
(Assignee)

Comment 11

9 years ago
Comment on attachment 319032 [details] [diff] [review]
Patch for News v5

I added this one to the website with a few modifications.
Attachment #319032 - Flags: review?(LpSolit) → review+
(Assignee)

Updated

9 years ago
Attachment #319032 - Attachment description: Patch for Release/news v5 → Patch for News v5
(Assignee)

Comment 12

9 years ago
Created attachment 319456 [details]
Release Announcement
Assignee: cedric.corazza → mkanat
Status: NEW → ASSIGNED
Attachment #319456 - Flags: review?(LpSolit)

Comment 13

9 years ago
Comment on attachment 319456 [details]
Release Announcement

>You can read the security advisory describing the fixed issues here:
>
>  http://www.bugzilla.org/security/3.0.4/

This URL is wrong. Must be http://www.bugzilla.org/security/2.20.5/. Otherwise looks good. r=LpSolit with the URL fixed.
Attachment #319456 - Flags: review?(LpSolit) → review+
(Assignee)

Comment 14

9 years ago
  Okay, news posted (yesterday) and release announcement sent out (just now).
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.