Disabling one plugin in plugin manager will disable all plugins for that type

VERIFIED DUPLICATE of bug 19118

Status

()

--
minor
VERIFIED DUPLICATE of bug 19118
11 years ago
10 years ago

People

(Reporter: pekka.lampila, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3) Gecko/2008021319 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9b3) Gecko/2008021319 Firefox/3.0b3

If you have multiple plugins for the same thing installed and disable one of them in the plugin manager, the other plugin will _not_ be used instead.

In my case I have both Adobe and Swfdec plugin for Flash, and would like to be able to choose which one to use.

Reproducible: Always

Steps to Reproduce:
1. Install Adobe and Swfdec Flash plugins
2. Disable the one that appears first in the list at plugin manager
Actual Results:  
Flash files will no longer be shown at all

Expected Results:  
Flash files will be shown by the plugin that was not disabled
That is no plugin manager, it's a helper application manager and you can only assign a filetype handled by a plugin to a helper application.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 94035
That seems the wrong dupe. It seems reasonable to think that after disabling a plugin that the next plguin that supports the type should take over. This is really something like bug 19118
Duplicate of bug: 19118
sorry, you are right, i pasted the wrong bug number ( i meant to dupe it to the plugin manager bug)

Updated

11 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.