talkback version does not match application version

VERIFIED WONTFIX

Status

Release Engineering
General
VERIFIED WONTFIX
10 years ago
4 years ago

People

(Reporter: juanb, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
While testing Tbird 20012 I noticed that the Talkback version string you get from the Add-ons dialog says "Talkback 2.0.0.9".

Steps:
1. Install Thunderbird 2.0.0.12rc1
2. Go to the Tools menu and select Add-ons

Expected: The Talkback version string should say "Talkback 2.0.0.12"

Actual: It says "Talkback 2.0.0.9" 

The master.ini has the correct build ID. It's just the string displayed in the Add-ons dialog that is wrong.
Flags: blocking1.8.1.13?
Problem seems to be in its install.rdf:

<em:targetApplication>
      <!-- Thunderbird -->
      <Description>
        <em:id>{3550f703-e582-4d05-9a08-453d09bdfdc6}</em:id>
        <em:minVersion>2.0.0.9</em:minVersion>
        <em:maxVersion>2.0.0.*</em:maxVersion>
      </Description>
    </em:targetApplication>

Comment 2

10 years ago
This is on purpose. We use a prebuilt Talkback package for Firefox and Thunderbird now (bug 403701), rather than building it from scratch every time. The Talkback versions were taken from existing releases, specifically:

Firefox:     2.0.0.12
Thunderbird: 2.0.0.9

These were the most up-to-date releases when the packages were created (the packages were obviously created recently). 

We could twiddle the version number in the Talkback package, but it wouldn't be accurate, i.e. 2.0.0.9 *is* the correct version number for the version of Talkback included with Thunderbird.

The latest comments seem to say we don't need this, clearing blocking request.
Flags: blocking1.8.1.13?
Not an installer bug
Component: Installer → General
QA Contact: installer → general

Comment 5

10 years ago
The code for Talkback honestly hasn't changed since the Netscape era. I don't think people would be complaining here if we hadn't always been tagging Talkback with along with Firefox. If the extension version number were stuck at something like '1.0.2' rather than something *almost* the same as the current Firefox version, would we care?

So, do we want to munge the Talkback version number to match the app version, or can we WONTFIX this?
Component: General → Build & Release
Product: Thunderbird → mozilla.org
QA Contact: general → build
Version: 2.0 → other
Especially given that it's gone on trunk anyway...

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
(Assignee)

Updated

4 years ago
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.