Clicking imagemap does not go to the right page

VERIFIED DUPLICATE of bug 30178

Status

()

P3
normal
VERIFIED DUPLICATE of bug 30178
19 years ago
17 years ago

People

(Reporter: wd, Assigned: harishd)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.12-20 i586; en-US; m16) Gecko/20000606
BuildID:    2000060608

When I click any of the "icons" on this page's imagemap, Mozilla does not go to
the right page.   It comes up with an error page.

Reproducible: Always
Steps to Reproduce:
1.Go to http://winfiles.cnet.com/drivers
2.Click one of the icons
3.

Actual Results:  Error saying "You have tried to access a page that does not exist!"

Expected Results:  The appropriate page comes up.

Perhaps this is because of a recent change from http://www.winfiles.com to http:
//winfiles.cnet.com?
I'm not sure if I picked the right component for this bug, since I have no clue
of what's causing it.

Comment 1

18 years ago
Reassigning to Nisheeth for further triage.
Assignee: clayton → nisheeth

Comment 2

18 years ago
Passing half of bugs from clayton's list to harish for triage...
Assignee: nisheeth → harishd
(Assignee)

Comment 3

18 years ago
It does seem to work for me ( June 06th build )!.
Status: NEW → ASSIGNED
(Reporter)

Comment 4

18 years ago
This still does not work for me with 2000061220
Linux, Win95, and Win98

Comment 5

18 years ago
Ok, I was able to reproduce the problem on the June 6th build. But the problem 
turns out to be a error in the HTML. Just before the MAP element, there is a A 
element that is closed. It's href is applied to MAP. If you comment this element 
out, all of the links in the image function in NS6.According to the HTML 4 DTD, A 
element should only contain inline elements. MAP is a block type element.

Comment 6

18 years ago
Sorry, the A element is NOT closed so it's href is applied to the Map element.
(Assignee)

Comment 7

18 years ago
I don't see the problem at all ( June 13the build ). Marking WORKSFORME.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 8

18 years ago
The problem is still here with 2000061408
Since this is newer than the version you tested with (June 13th), I am re-
opening.   Chris, are you still able to reproduce as you did with the June 6th
build?
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Assignee)

Comment 9

18 years ago
My fault. Chris, explained to me what was going on...and I understand the 
problem now..doug.  I din't pay attention to the "File not found" 
message..because it looked more like an image banner than an error message.  
Sorry about that folks...will look into the problem.
Status: REOPENED → ASSIGNED
(Assignee)

Comment 10

18 years ago
Created attachment 10145 [details]
Reduced case [ Click only on "Newest Drivers"]
(Assignee)

Comment 11

18 years ago
BTW, MAP is inline and A can contain it.

CONTENT-MODEL:

docshell=01C773B0
html@033849E8 refcount=3<
  head@033848F8 href=http://winfiles.cnet.com/drivers/ refcount=2<
    base@033AE078 href=http://winfiles.cnet.com/drivers/ refcount=2<>
  >
  Text@033A88F0 refcount=3<\n\n>
  body@033A8B08 bgcolor=#ffffff text=#000000 link=#000080 vlink=#800080 backgrou
nd=/gifs/backgrounds/cloudtile.jpg refcount=3<
    Text@01C8CC10 refcount=3<\n\n>
    center@01C8A818 refcount=3<
      Text@01C89170 refcount=3<\n\n>
      a@01C8D98C href=/cgi-bin/imagemap/gifs/imaps/drivers_index.map refcount=3<

        Text@01C885A0 refcount=3<\n\n>
        map@01C8FAC8 name=drivers_index refcount=3<
          area@01C8D65C shape=RECT coords=79,53,156,121 href=/drivers/newdrivers
.html refcount=2<>
        >
        Text@01C8C760 refcount=3<\n\n>
        img@01C8E7FC width=470 height=305 src=/gifs/imaps/drivers_index.gif bord
er=0 ismap= usemap=#drivers_index alt=Click an icon to visit an area refcount=3<
>
      >
      Text@01C8F200 refcount=3<\n\n>
    >
  >
>

I think the problem has to be addressed in Layout rather than Parser.  If it has 
to be handled in the parser then we have to make it a special case! Any comments 
....suggestions?
(Assignee)

Comment 12

18 years ago
I strongly believe..that this is a LAYOUT bug.

*** This bug has been marked as a duplicate of 30178 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 14

18 years ago
massive update for QA contact.
QA Contact: petersen → lorca

Comment 15

18 years ago
Marking VERIFIED.
Status: RESOLVED → VERIFIED
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout
You need to log in before you can comment on or make changes to this bug.