The extension did not run as it was not complying with Vista's (64 bit) UAC

RESOLVED INCOMPLETE

Status

()

Firefox
Extension Compatibility
--
major
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: Ajay, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-15])

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

The firefox extension stops working after upgrading Firefox to version 2.0.0.8 and
above. (also noticed on version 2.0.0.12)
It is noticed the on a Microsoft Vista 64 bit OS having UAC (User Account Control)
switched-on, the firefox browser API [nsIProcess.run()] fails when launching an executable that has elevated privileges, even though the we have marked the executable as requestedExecutionLevel level="requireAdministrator" using a manifest file.


Reproducible: Always

Steps to Reproduce:
1. Launch an executable using the XUL API nsIProcess.run() on a 64 bit Vista environment using firfox version 2.0.0.8 or above
(Note: Mark the executable as requestedExecutionLevel level="requireAdministrator" using a manifest file)

Actual Results:  
The XUL API nsIProcess.run() throws an exception 

Expected Results:  
The executable  should run.

(Note: Mark the executable as requestedExecutionLevel level="requireAdministrator" using a manifest file)

Work-arounds
------------
1. Right-click the Mozilla Firefox EXE or its shortcut and select "Run as
administrator" from the context menu.
2. Right-click the Mozilla Firefox shortcut and select properties. Click the
advanced button (Shortcut Tab) and check the "Run as administrator" checkbox.
3. Right-click and select properties. Click the "Show Settings for all users"
(Compatibility Tab) and check the "Run as administrator" checkbox.
4. Login as a real Administrator and run from there.
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.