Please put Prev and Next scroll arrows for month view adjacent to each other instead of on opposite sides of the screen.

VERIFIED FIXED in 0.9

Status

Calendar
Calendar Views
--
enhancement
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Rob Steves, Assigned: Berend Cornelius)

Tracking

unspecified
Bug Flags:
wanted-calendar0.9 +

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Lightning Ver 0.7

Currently here is an example of the month view header:

<       january    february   MARCH 2008   april   may         >
----------------------------------------------------------------

Note the two arrows "<" and ">" for scrolling to the previous or next months are are opposite sides of the screen. This makes it pretty annoying to scroll backwards and forwards through time. A better arrangement would be as follows:

Option 1 (single set of adjacent arrows on one side):

<>       january    february   MARCH 2008   april   may        
----------------------------------------------------------------

Option 2 (double set of adjacent arrows, one set on each side):

<>       january    february   MARCH 2008   april   may       <> 
----------------------------------------------------------------

Then you don't need to move your mouse cursor all the way across the screen to scroll backwards and forwards in time. This applies to the Day, Week, Multiweek, and Month views. Making this change in the miniature calendar view would also be nice, but here it is not as much an issue since the two arrows are relatively close together already.


Reproducible: Always

Steps to Reproduce:
View calendar
Actual Results:  
Prev and next arrows are on opposite sides of the screen.

Expected Results:  
Prev and next arrows should be adjacent to each other for ease of scrolling backward and forward through time.

Comment 1

10 years ago
Thanks for filing that bug. Momentarily the user experience is really not optimal. We'll change that with .9.
See http://wiki.mozilla.org/images/2/22/Calendar-view-w-tasks.png

Comment 2

10 years ago
Requesting wanted .9
Flags: wanted-calendar0.9?

Comment 3

10 years ago
confirming per comment #1
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: wanted-calendar0.9? → wanted-calendar0.9+

Comment 4

10 years ago
This was implemented in bug 444292.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Target Milestone: --- → 0.9
Assignee: nobody → Berend.Cornelius
You need to log in before you can comment on or make changes to this bug.