Status

()

--
critical
VERIFIED DUPLICATE of bug 417819
11 years ago
11 years ago

People

(Reporter: jmjeffery, Unassigned)

Tracking

({crash})

Trunk
x86
Windows Vista
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021411 Minefield/3.0b4pre Firefox/3.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021411 Minefield/3.0b4pre Firefox/3.0

this page is crashing.

http://stereo-club.fr/GalerieSCF/main.php?cmd=imageview&var1=n07113006g1d_X.jps&var2=3
Click on the 3D glasses - crash!

On IE it loads in a pop-up window. 

Reproducible: Always

Steps to Reproduce:
1. Visit the URL 
2. Click on the 3D glasses - top right of image
3. Crash immediately or on close of the window.
Actual Results:  
Crash
Event viewer shows:
Faulting application firefox.exe, version 1.9.0.2964, time stamp 0x47b4a0dc, faulting module js3250.dll, version 4.0.0.0, time stamp 0x47b4a137, exception code 0xc0000005, fault offset 0x00038ec0, process id 0xcf8, application start time 0x01c86f73f05136b0. 

breakpad:
http://crash-stats.mozilla.com/report/index/4f32010a-db69-11dc-98be-001a4bd43e5c

Expected Results:  
No crash - pop-up window displayed. 

Vista HP fully updated
Java 1.6.0_4 (latest)
(Reporter)

Updated

11 years ago
Version: unspecified → Trunk
Sorry - forgot - No idea when this started, and I don't have a regress range.  I only visited the page first time yesterday.

Comment 2

11 years ago
Crash with WinXP as well:
http://crash-stats.mozilla.com/report/index/b852b03a-dba3-11dc-a302-001a4bd43ef6

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021404 Minefield/3.0b4pre ID:2008021404

WinXP Pro SP3
Java 1.6.0_4
0 js_FinishSharingScope  
1 js_LockObj  
2 JS_SetPrototype  
3 JS_GetPrototype  
4 XPCWrappedNative::GetNewOrUsed(XPCCallContext&, nsISupports*, XPCWrappedNativeScope*, XPCNativeInterface*, int, XPCWrappedNative**) mozilla/js/src/xpconnect/src/xpcwrappednative.cpp:537  
5 XPCConvert::NativeInterface2JSObject(XPCCallContext&, nsIXPConnectJSObjectHolder**, nsISupports*, nsID const*, JSObject*, int, int, unsigned int*) mozilla/js/src/xpconnect/src/xpcconvert.cpp:1106  
6 nsXPConnect::WrapNative(JSContext*, JSObject*, nsISupports*, nsID const&, nsIXPConnectJSObjectHolder**) mozilla/js/src/xpconnect/src/nsXPConnect.cpp:1241  
7 nsDOMClassInfo::WrapNative(JSContext*, JSObject*, nsISupports*, nsID const&, long*, nsIXPConnectJSObjectHolder**) mozilla/dom/src/base/nsDOMClassInfo.cpp:1568  
8 nsHTMLDocumentSH::GetProperty(nsIXPConnectWrappedNative*, JSContext*, JSObject*, long, long*, int*) mozilla/dom/src/base/nsDOMClassInfo.cpp:8384  
9 XPC_WN_Helper_GetProperty mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp:954  
10 js_NativeGet  
11 js_GetPropertyHelper  
12 js_Interpret  
13 js_Execute  
14 JS_EvaluateUCScriptForPrincipals 
.......
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → JavaScript Engine
Ever confirmed: true
Keywords: crash
Product: Firefox → Core
QA Contact: general → general
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417819
The patch attached to bug 417819 seems to fix this for me so duping.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.