Firefox indicates restart required when no addons were updated.

RESOLVED DUPLICATE of bug 401123

Status

()

--
minor
RESOLVED DUPLICATE of bug 401123
11 years ago
10 years ago

People

(Reporter: astonerbum, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b3) Gecko/2008020514 Firefox/3.0b3

When trying to update addons, if none need updates Firefox still indicates that a restart is required.

Reproducible: Always

Steps to Reproduce:
1. Go to addons window.
2. Click find updates.
3. Ensure that no updates are found
4. Notice restart required appears at the top of the addon window even though it is unnecessary.
Actual Results:  
Restart required is shown.

Expected Results:  
Restart required is not shown.

Not a critical bug, but to a user who is not familiar with Firefox, this will discourage them from looking for addon updates because they will believe it requires a restart effort.
The notification that appears at the top reads "No updates found" for me, nothing about requiring a restart. Are you sure the request to restart wasn't already present when opening the addons window?
Component: General → Extension/Theme Manager
QA Contact: general → extension.manager
(Reporter)

Comment 2

11 years ago
Sorry, bad QA work on my part.

I have not been able to reproduce this situation consistently. It is possible that there was an update not indicated in the UI.

However, there was no restart required present before the update. I will keep checking.
(Reporter)

Comment 3

11 years ago
Flashblock plugin was updated at that time, but there was no indication that the plugin was updated, so the restart required was appropriate. However it is a problem that there was no notification of what was installed.

Updates were
Flashblock for Firefox 3b2 -> Flashblock for Firefox 3b3.
What was the version of flashblock before and after the update? Or was it just a compatibility update that made flashblock compatible?
(Reporter)

Comment 5

11 years ago
Compatibility update I believe. Currently 1.5.5
Ok so it is probably right that the restart option was given (with the new compatibility info flashblock would be marked to be enabled which requires a restart). The fact that the feedback about compatibility updates is not good is known so duping to there.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 401123
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.