Checking for update details deletes all saved tabs

RESOLVED DUPLICATE of bug 361129

Status

()

Firefox
Session Restore
--
major
RESOLVED DUPLICATE of bug 361129
10 years ago
9 years ago

People

(Reporter: Painter, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Was using Firefox 2.0.0.11. Many times have received a notification about a new Firefox 2.0.0.12 release and finally decided to do it after another Firefox crash. Run Firefox and started to download the update via the update pop-up window. Was told that the download was successful and I need to reload. And so I did (killed the application). I run application one more time, received:
1. a window with the proposal to reload all tabs
2. a window with the information that update wasn't installed/download properly and it is needed to be downloaded and installed again. I agreed. The download began.

As download was going on, I didn't touch the first window. But I decided to check out what new does Firefox 2.0.0.12 brings and clicked at the "more details" (don't remember the exact wording) button in the second window. The Firefox loaded with this lonely page. I checked the info and closed the window.

At some point the process of downloading and installing was over and I was suggested to reload the application. Then I realized, that there may be a bug going on: it I closed the window with one tab, then there is a chance that it will also be saved in SessionManager. I had nothing to lose and since I still had my first window on screen, I pressed the "reload tabs" button. And I was correct - all my tabs were gone! Of course then I closed the browser and rerun it, but all my tabs were still away!..

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.


Expected Results:  
The window(s) opened via "more details" link, shouldn't be automatically saved in default Session. Maybe the question should be asked from user ("You have two conflicting default sessions. Which one you want to leave?") or saved automatically under another name. Or it shouldn't be saved at all. The main point being that the original session should stay intact!
(Reporter)

Updated

10 years ago
Version: unspecified → 2.0 Branch

Updated

10 years ago
Component: Installer → Session Restore
QA Contact: installer → session.restore

Comment 1

9 years ago
(In reply to comment #0)
> Was told that the download was successful and I need to reload. And so
> I did (killed the application).

Did you kill the Firefox process or did Firefox do that itself? If the latter, then at least that bit (and with it hopefully the main cause for this bug) has been fixed with Firefox 3.0.

Otherwise this bug is similar to bug 361129 and would be fixed by fixing bug 381887.
Severity: critical → major
Status: UNCONFIRMED → NEW
Depends on: 381887
Ever confirmed: true
(Reporter)

Comment 2

9 years ago
(In reply to comment #1)
> Otherwise this bug is similar to bug 361129 and would be fixed by fixing bug
> 381887.

It indeed seems like a duplicate. 
(Reporter)

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 361129
You need to log in before you can comment on or make changes to this bug.