Reflect 2008 Changes in Australian Daylight Saving Times

VERIFIED FIXED in 0.8

Status

Calendar
Internal Components
--
minor
VERIFIED FIXED
10 years ago
10 years ago

People

(Reporter: Hb, Unassigned)

Tracking

unspecified

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

10 years ago
Created attachment 303609 [details] [diff] [review]
Patch for tzdata.c

Error corrections:

The standard time for Adelaide has bad offsets: Standard time TZOFFSETFROM and TZOFFSETTO are both +0930 and need to be TZOFFSETFROM:+1030 TZOFFSETTO:+0930. This affects Cairo too.

New Australia DT/DST switching dates:

Australia Eastern (NSW, VIC, ACT and Tasmania) and Central (SA) time zones were changed in April 2008. Daylight saving ends on the first Sunday in April and starts on the first Sunday in October, see http://www.australia.gov.au/Time

I predict that after the great "Western Australia Daylight Saving Trial 2006 – 2009" which affects the Perth time zone the referendum will give a GO for daylight saving time. The DT/DST switch days will be changed to the dates mentioned above.

Notice that the daylight saving time on the Lord Howe Island shifts only 30 minutes from standard time.
Attachment #303609 - Flags: review?(daniel.boelzle)
How old is this change? Is it already included in the 2007k release of the Olson timezone database? If yes the changes should be already included in the patch in Bug 410931.
(Reporter)

Updated

10 years ago
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 410931
(Reporter)

Updated

10 years ago
Attachment #303609 - Attachment is obsolete: true
Attachment #303609 - Flags: review?(daniel.boelzle)
Status: RESOLVED → VERIFIED
Target Milestone: 0.9 → ---
(Reporter)

Updated

10 years ago
Resolution: DUPLICATE → FIXED
Patch included in bug 410931.
Target Milestone: --- → 0.8
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.