In table cell, width="0px" is ignored, but style="width: 0px" is honored

VERIFIED DUPLICATE of bug 417826

Status

()

VERIFIED DUPLICATE of bug 417826
11 years ago
11 years ago

People

(Reporter: dholbert, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
In Trunk on a table cell, we honor
  style="width: 0px"
as a specified-width of 0px, but we ignore
  width="0"
and treat it as auto-width.

This was noted in https://bugzilla.mozilla.org/show_bug.cgi?id=413286#c19.  The auto-width behavior is due to nsHTMLTableCellElement.cpp:338, with the explanatory comment "0 implies auto for compatibility."

We should make the behaviors of styled zero-width and attribute zero-width consistent -- either ignore both, or honor both.
(Reporter)

Comment 1

11 years ago
Bugzilla died while this bug was being created, and it made two copies...
Resolving this copy as a dupe of the other one.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 417826

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.