Firefox leak nsThread and nsTimerImpl when Personas is installed

RESOLVED WORKSFORME

Status

()

Core
General
P2
normal
RESOLVED WORKSFORME
10 years ago
10 years ago

People

(Reporter: Tomcat, Unassigned)

Tracking

({mlk})

Trunk
x86
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 303648 [details]
leak log 

Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9b4pre) Gecko/2008021514 Firefox/3.0b4pre

0 TOTAL                                          29      132   435985        2 ( 1575.34 +/-  1772.43)  1424513        2 ( 2076.57 +/-  3249.25)

Note: this leak seems not 100% reproducible, but i was able to reproduce this several times by using the "Most Popular-> Random Selection from Most Popular" (last leak i got was with reindeer mask)

Steps to reproduce:
* New Firefox Profile
* Install Personas from http://labs.mozilla.com/featured-projects/#personas
* After Restart you have 3 Tabs (Mozilla Labs Page, Firefox Default Startpage and the Personas for Firefox Page http://people.mozilla.com/~cbeard/personas/en-US/firstrun/?version=0.9.1
* Play a little with the Firefox Masks
* Quit Firefox

--> Leak
Flags: blocking1.9?
(Reporter)

Comment 1

10 years ago
Created attachment 303650 [details]
leak log when i have also open a SSL site with Bugzilla

it seems that this leak might be also the same issue like in bug 417642, since the leak report looks very similar when i have also a SSL Tab open (like bugzilla.mozilla.org)
(Reporter)

Updated

10 years ago
Depends on: 417642
Flags: blocking1.9? → blocking1.9+
Priority: -- → P3
Hopefully this is a dupe of 417642 ...
Flags: tracking1.9+ → blocking1.9+
Priority: P3 → P2
Carsten, can you check that this is indeed a duplicate of bug 417642.
(See bug 417642 comment 3)

Comment 4

10 years ago
WFM. Probably fixed by bug 420521.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.