Logging into a webct / blackboard site causes browser to crash with adblock enabled

RESOLVED WORKSFORME

Status

()

--
critical
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: marcuri26, Unassigned)

Tracking

({crash, regression})

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021504 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9b4pre) Gecko/2008021504 Minefield/3.0b4pre

I have a new issue with either the current nightly or the previous one as I had a discussion post required for my class due on Wednesday and the issue wasn't present. Apparently adblock plus 0.7.5.3 being enabled (went through the addons one by one once a standard profile didn't cause this problem) along with a recent version of blackboard's webct (also known as webcourses at some universities) and loading the initial webct webpage after log in causes the browser to crash. This did not happen before, as a matter of fact an issue with webct was just fixed so maybe someone developed a bug fix without taking into account this new code that's been patched in a few days ago. The bug I'm referencing is this one: https://bugzilla.mozilla.org/show_bug.cgi?id=412324 . For me the specific problem occurs with my school's webcourses page (latest webct version i believe) its: webcourses.ucf.edu and it happens after logging in while the browser is loading the page after clicking "ok" on the page. Ad block has the easylist+easyelement filter installed however deleting it doesn't make a difference. With no filters it causes this problem as well, only disabling works. I also tried the latest Dev build (0.7.5.3+ 2008011108) I have a few crash reports on it:
http://crash-stats.mozilla.com/report/index/f682e80a-dc42-11dc-953e-001a4bd43ed6
http://crash-stats.mozilla.com/report/index/bec9afde-dc42-11dc-9e77-001a4bd43ef6
http://crash-stats.mozilla.com/report/index/762d5af8-dc3f-11dc-890c-001a4bd43ed6

Note that this doesn't seem to be an adblock problem due to the fact that I had adblock installed and enabled when the patch for bug 412324 landed. This seems to be a problem caused by a patch within the last 3 days at very most.

Reproducible: Always

Steps to Reproduce:
1. Have latest adblock installed (mine was 0.7.5.3)
2. Nightly build 2008021504 
3. Log into a webcourses / webct / latest blackboard site such as webcourses.ucf.edu
It would help a lot if you can find the exact regression window by
installing nightly trunk builds prior to 2008021504 from here:
http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/
Thanks.
Keywords: crash, regression

Comment 2

11 years ago
I can see this crash as well - it has to do with the Java applets on this page, without them no crash happens.

Comment 3

11 years ago
Looks like I wasted my time on that one - I can no longer reproduce it with the 2008021607 build. So this is likely a dupe of bug 417819 (maybe Matt can resolve it as such if the problem is fixed for him as well). Since I've done my analysis already:

The website doesn't crash on login reliably for me - however, if I wait for the website to load and cancel Java's security requests only then it will always crash. Blocking the objects in Adblock Plus makes the crash go away. Without Adblock Plus the crash doesn't happen either but adding a minimal JavaScript content policy brings it back. Regression range is 2008-02-13-04 to 2008-02-14-04.

My crash reports (only the ones with a different stack):

http://crash-stats.mozilla.com/report/index/da674be8-dcc7-11dc-8c24-001a4bd43ef6
http://crash-stats.mozilla.com/report/index/817661e8-dcc6-11dc-8485-001a4bd43ed6
http://crash-stats.mozilla.com/report/index/a61b0168-dcc4-11dc-aec9-001a4bd43e5c

Prime suspect is bug 408871.
marking worksforme, please reopen if you get this again
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

11 years ago
uh yea.. it works :-\.. sorry for the hassle Palant.. it seemed serious enough and new enough that I figured I'd make a report.

Anyway it seems bug 408871 (briefly looking at it) must've been the culprit.
You need to log in before you can comment on or make changes to this bug.