Javascript not working the way it should

VERIFIED INVALID

Status

()

P3
major
VERIFIED INVALID
19 years ago
17 years ago

People

(Reporter: cheng, Assigned: rogerl)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

19 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.2.14-12 i686; en-US; m16) Gecko/20000606
BuildID:    2000060608

When you load this page with Netscape 4.x, you will see that moving the cursor
over the items on the left hand side brings up pop-up menus.  Instead, Mozilla
put the menus at the bottom of the screen, and complained about:

JavaScript error:
http://www.spaceflight.nasa.gov/index-n.html line 89: document[m] has no properties

JavaScript error:
http://www.spaceflight.nasa.gov/index-n.html line 91: document[m] has no properties

a few times.  I do not know anything about Javascript to understand what the
problem is from the source.

Reproducible: Always
Steps to Reproduce:
1.Just go to the web site.

Comment 1

19 years ago
It seems to display the same errors in IE,  the webpage seems to be coded using 
layers, it needs to replace the layers with divs, and set it to detect IE and 
netscape 6.0 (mozilla) as deserving of the divs.

Comment 2

19 years ago
Marking invalid.
Mozilla isn't going to support Layers.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → INVALID

Comment 3

18 years ago
Verified invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.