undo after reopening bookmarks manager fails (Components is not defined)

RESOLVED FIXED in seamonkey2.0b2

Status

SeaMonkey
Bookmarks & History
RESOLVED FIXED
11 years ago
9 years ago

People

(Reporter: Andrew Schultz, Unassigned)

Tracking

Trunk
seamonkey2.0b2
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Fixed by bug 342296])

(Reporter)

Description

11 years ago
With current seamonkey trunk, If I try to undo something after reopening the bookmarks manager window, the undo fails with various exceptions.

1. In the bookmarks manager, perform some action (drag/drop a  bookmark)
2. Close the bookmarks manager
3. Open the bookmarks manager
4. Select edit->undo from the menu

==>
Error: Components is not defined
Source File: chrome://communicator/content/bookmarks/bookmarks.js
Line: 1731
(twice)

and
Error: [Exception... "Component returned failure code: 0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS) [nsITransactionManager.undoTransaction]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: chrome://communicator/content/bookmarks/bookmarks.js :: anonymous :: line 409"  data: no]
Source File: chrome://communicator/content/bookmarks/bookmarks.js
Line: 409
(Reporter)

Comment 1

11 years ago
*sigh*

if I ignore "XXXvarga Can't use |RDFC| here because it's being "reused" elsewhere." and just use RDFC in undoTransaction, this bug seems to go away and I don't notice any adverse affects.  The other undo functions use RDFC and apparently have no problem.

Comment 2

11 years ago
Bug 342296 should fix this, but it needs someone willing to review RDF...
(Reporter)

Updated

11 years ago
Depends on: 342296
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.1pre) Gecko/20090717 SeaMonkey/2.0b1] (release) (W2Ksp4)

I don't reproduce the errors (anymore).
But I confirm that 'Undo' does nothing.

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.1.4pre) Gecko/20090903 SeaMonkey/2.0b2] (release) (W2Ksp4)

R.Fixed.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
OS: Linux → All
Resolution: --- → FIXED
Whiteboard: [Fixed by bug 342296]
Target Milestone: --- → seamonkey2.0b2
You need to log in before you can comment on or make changes to this bug.