Page content on MSDN is not being displayed

RESOLVED WONTFIX

Status

()

--
major
RESOLVED WONTFIX
11 years ago
11 years ago

People

(Reporter: mcsmurf, Unassigned)

Tracking

({regression})

Trunk
x86
Windows XP
regression
Points:
---
Bug Flags:
blocking1.9 -

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
To reproduce:
1. Go to URL

Observe that the content on the right side is blank. If you drag the gray line on the left to the left side of the window to close the table of contents, the content usually appears again.

This regressed between 2008-01-28-02 and 2008-01-29-02.
(Reporter)

Comment 1

11 years ago
Looks like this was caused by Bug 134706, tested via local back-out. Not sure if this bug here is valid as another dep of that bug (Bug 415252) was marked invalid. Probably need further analysis of the MSDN site here (and/or testcase).
Blocks: 134706
Component: General → Layout
QA Contact: general → layout
(Reporter)

Updated

11 years ago
Summary: Page content on MSDN is not displayed → Page content on MSDN is not being displayed
(Reporter)

Comment 2

11 years ago
Waldo confirmed this bug.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

11 years ago
The problem is caused by long unbreakable strings of text down the page (under 'Community Content').

The sidebar is a floated block, the right column is _basically_ a block with 'overflow:auto' set; in it there is also a block with overflow:hidden. Both columns within another block with 'position:fixed, bottom:0'. For some reason I haven't fully understood yet, those long strings cause the right column to expand in width (too wide to fit next to the floated left column), it then drops below the float, but becomes invisible.

Maybe 'overflow:hidden' clips those long strings visually, but the overflowing strings still affect the width of the parent block ?

WebKit wraps those long strings to the width of the column, Opera doesn't wrap those lines, but doesn't drop the column / expand the width of the column as Gecko does.

Comment 4

11 years ago
Created attachment 303853 [details]
sort-of-reduced testcase

Not completely the same as what MSDN does, but close, and it illustrates the issue, I think.
The right column drops below the left column in Gecko, but not in WebKit or Opera 9.5.

Note also: MSDN set 'overflow:hidden' on the root element (html). I had missed that first pass around.

Comment 5

11 years ago
Created attachment 303854 [details]
sort-of-reduced testcase

oops, I attached the wrong file :(
Attachment #303853 - Attachment is obsolete: true
(Reporter)

Comment 6

11 years ago
David: Can you check what is going on here?
(Reporter)

Comment 7

11 years ago
Maybe a regression. Not sure though as the rendering changed and if the new rendering is correct and so being no regression. Requesting blocking1.9 due to that.
Flags: blocking1.9?

Updated

11 years ago
Flags: tracking1.9? → blocking1.9?
Our behavior on attachment 303854 [details] looks correct to me.

Is this specific to one MSDN page or a general problem?
(Reporter)

Comment 9

11 years ago
Specific to that page, probably because of the very long user comment at the end of the page.
Looks like WONTFIX as far as we know.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 11

11 years ago
Clearing flag in that case.
Flags: blocking1.9?
You need to log in before you can comment on or make changes to this bug.