Plugins shouldn't have to be reinstalled upon installing Firefox into a different directory

RESOLVED INVALID

Status

()

--
enhancement
RESOLVED INVALID
11 years ago
11 years ago

People

(Reporter: r_rom, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021404 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021404 Minefield/3.0b4pre

One way to solve it is to install plugins into a shared profile directory. Another is to offer to import plugins from a previous install dir to a new one (this should involve checking plugins' versions and offering to update them if needed).

Reproducible: Always
The Plugin vendor decides where it wnats the Plugins installed.
We can't change the installation direcotry for plugin like Flash, Java, Realplayer.

marking invalid

Or Do you mean extensions/Addons ?
In that case write a new bug report about Addons/Extensions
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

11 years ago
If Mozilla developers move the plugins directory to where the profiles are located and notify the vendors, they will change their installation programs. The devs could create a directory for plugins in the profiles location and temporarily load plugins from there and from the current location (in this order). Developers have broken third-party extensions multiple times. What's so special about influencing the way plugins are dealt with? Perhaps, you've misunderstood my request, so I am reopening this issue to get input from others.

When there's a will, there's a way.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Again, Do you really mean Plugins (like Java, Flash, Realplayer, quicktime) or do you mean addons/extensions like Adblock, IEtab ?

It can't be done for plugins because plugins are not only used by Firefox, they are used by all browsers except IE5+ and they don't belong into a Firefox specific profile directory. 
It makes no sense to install a plugin only for a current profile and you can also disable plugins for each profile in the Helper application config.


(Reporter)

Comment 4

11 years ago
Yes, I do mean plugins (Windows Media Player, etc.).

(In reply to comment #3)
> It makes no sense to install a plugin only for a current profile

I didn't suggest this. I suggested to install plugins into a *shared* profile directory. Perhaps, I used a confusing term. I meant a directory that would be shared by all profiles. This way when a new version of Firefox is installed into a new directory, all previously installed plugins will be available because Firefox will look into that directory automatically.

(In reply to comment #3)
> you can also disable plugins for each profile in the Helper application >config.

My suggestion wouldn't make that impossible.

The fact that plugins are also used by other browsers doesn't mean what I asked for can't be done. Can you explain to me what specifically, in your view, makes my request impossible to implement?
Hwo about a "general system shared plugin directory" ?
flash installs currently in c:\windows\system32\macromedia, Java install under c:\program files\java\... , and this plugins are found from different Browser installtions.

But the plugin vendors decides how and where they install a plugin, I don't think we can anything to establish a system shared directory because the current installation systems works without problems.


(Reporter)

Comment 6

11 years ago
Actually, no, not without problems. The reason I filed this request is because there are problems.

I installed a new version of Firefox and found myself having to install some plugins (e.g. Quicktime and Windows Media Player). The difference in numbers of files in plugins directory under install dirs of FF 2 and FF 4 pre (14 vs 2) tell me that I will have to reinstalled quite a few plugins. I am not a robot to keep doing what I've already done. I'd like my PC to be the robot, and software I use should help me do less repetitive actions.

With Windows Media Player I had to do some hacking with files that will prevent computer newbies from being able to use this plugin if they install FF 3 into a new directory. I had WMP plugin installed and working with FF 2, but I after installing FF 3 I lost ability to listen to Window Media streams. Firefox is unable to install this plugin by itself and needs the user to do the job for it. Because I am a technical guy, I've found the installation program and ran it, and... I was told that plugin was already installed. Presumably, the installation dir of FF 2 was meant. So, I had to copy a file that I happened to correctly guess was behind the WMP plugin to the plugins dir under installation dir of FF 3.

If you call that "works without problems", then our views of how user friendly software has to work differ.

If you and (other) Firefox developers insist that it's impossible to influence where plugins are installed, then, at least, you can implement my second suggestion described in my intial comment: "to offer to import plugins from a previous install dir to a new one (this should involve checking plugins' versions and offering to update them if needed)." Developers have been spent enormous amount of time on "one click bookmark mechanism" to reduce the bookmarking process by one click or one key press but are happy with forcing users to select and copy plugin files?
Firefox looks in a number of places for plugins. If a plugin decides to install itself into the app directory then of course you will have to reinstall if you install firefox elsewhere. Plugins are welcome to install in the user profile or indicate their location in the registry which would not cause this, it is up to the plugin vendors to do this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.