New Aero icons - problems on dark background for Stop/Reload buttons

RESOLVED FIXED in Firefox 3.7a2

Status

()

defect
RESOLVED FIXED
12 years ago
9 years ago

People

(Reporter: ronin.achilles, Unassigned)

Tracking

3.0 Branch
Firefox 3.7a2
x86
Windows Vista
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Reporter

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021504 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021504 Minefield/3.0b4pre

On dark backgrounds, I see the following issues with the new icons:

- Dropmarker on the keyhole is not visible
- Stop and Reload buttons have rough edges (or rather seem to have rough edges)

Please see the screenshot for more details.

Other icons seem fine.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Reporter

Updated

12 years ago
Blocks: 405605
Reporter

Comment 1

12 years ago
Screenshot.
Reporter

Comment 2

12 years ago
Changing Bug description to note that this is just a problem with Aero Stop/Reload buttons; the XP versions are fine.

In the XP version, there is a problem with the Keyhole, where its borders on a dark background are not sharp.
Summary: New icons - problems on dark background → New Aero icons - problems on dark background for Stop/Reload buttons
The glow that you are noting on stop and reload is standard for glyph icons on Vista.  We wanted to have it in place for when we get Aero glass support after Firefox 3.  If you are planning on placing the icons on a black glass toolbar, you will probably want to modify the Vista glyphs to remove the glow (you also might want the icons to be a brighter color).  I'll see if I can get the source files posted.

We need to fix the drop marker (on both Vista and XP).
Reporter

Comment 4

12 years ago
Actually I did notice that on a few Vista apps (Windows Live Photo Gallery for example). But, for now, while we don't have Aero Glass support, can't we not have the glow. Maybe we can check-in these icons (with the glow) as and when we introduce the Aero Glass support.

From the screenshot:

The stop/reload for XP look really nice on dark as well as light backgrounds - maybe we could use something similar for Vista theme.

Note: the rough edges of XP Keyhole on dark backgrounds.
>But, for now, while we don't have Aero Glass support, can't we not
>have the glow.

yeah that is certainly an option, I need to check what these look like using the classic OS theme as well to see if the glow is causing problems there as well.

>Note: the rough edges of XP Keyhole on dark backgrounds.

Yep, thanks for pointing that out.
Even with Glass turned on, the window frame will turn dark when the window is maximized and the glow is visible. I don't know if that's intended behavior or not.
>the window frame will turn dark when the window is maximized and the
>glow is visible.

good point

Comment 8

12 years ago
(In reply to comment #6)
> Even with Glass turned on, the window frame will turn dark when the window is
> maximized and the glow is visible. I don't know if that's intended behavior or
> not.
> 

The same happens in other apps in Vista, so it is consistent behavior.  For a good example, open Windows Media Player and maximize it.
Removing blocking 405605 since we are going to use that bug to track css changes.
No longer blocks: 405605
should be fixed by bug 546098
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Depends on: 546098
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a2
Version: unspecified → 3.0 Branch
You need to log in before you can comment on or make changes to this bug.