about: URLs do not appear in the location bar history dropdown

RESOLVED WONTFIX

Status

()

Firefox
Address Bar
RESOLVED WONTFIX
10 years ago
6 years ago

People

(Reporter: tchung, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008021504 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008021504 Minefield/3.0b4pre

the about: protocol does not seem to be supported in the location bar history dropdown.   about:license, about:config, etc...

Reproducible: Always

Steps to Reproduce:
1. load nightly build
2. in location bar, type in a about: site.  (eg. about:config, about:plugins)
3. Open a new tab, and verify typing in "about:" does not appear in the location bar history
Actual Results:  
about: supported in location bar?

Expected Results:  
about: not shown in location bar

Comment 1

10 years ago
That's done on purpose, in nsNavHistory::CanAddURI()

Updated

10 years ago
Summary: about: not supported in location bar → about: URLs do not appear in the location bar history dropdown
Yeah, this was by design; it's in one of Seth's comments, deeply nested in some bug which I can't find right now.
Indeed. It's been this way since forever: http://bonsai.mozilla.org/cvsblame.cgi?file=mozilla/docshell/base/nsDocShell.cpp&rev=1.104#2742

Perhaps we should reconsider? Might need to special-case about:blank.

Comment 4

10 years ago
Perhaps a setting to change this behavior? Maybe only triggered if about: (i.e not "ab" or "abou") is typed?

Updated

10 years ago
Duplicate of this bug: 462674
Actually, I think Bug 462674 is the proper way to fix this, if you type about:, you should get a dropdown of the available about: pages. Let me know if there are good reasons to not do it this way.

(And, I'm still a Bugzilla etiquette newbie, so let me know if it's inappropriate to mark this as a dupe of the other one. :)
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 462674
Not the same bug - this bug is about us not remembering any history for about: URIs, and that one is about auto-completing them automatically based on knowledge of available pages. We could fix both or either.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Updated

8 years ago
Status: REOPENED → NEW
I would argue that "history of about: pages" isn't that useful, since there is a limited set of them. Additionally, they are under-the-hood settings, and as such should remain somewhat hidden (ie. not show up until you've typed "about:")

Comment 9

8 years ago
I agree that bug 462674 sounds like the best way to go. This one could probably be closed as WFM if that's done. Nonetheless, these are different bugs for now.

(In reply to comment #8)
> Additionally, they are under-the-hood settings, and as such should
> remain somewhat hidden (ie. not show up until you've typed "about:")

Sounds like an argument for a wontfix for this bug, however if the user has already been to the page then there's not much point in hiding it further.
Right, maybe I should have done a wontfix (still learning :), I just thought it would be better to point to the other bug, since it'll essentially solve the same problem (in a slightly different way). 

So if I can make a case from the UX side of things, I'd prefer it to not enter into regular history, since it would pollute an external namespace (web sites) with an internal one (configuration and setting). It's not a good experience when about:config shows up in a list together with the links to about.com, for instance.

Just trying to clean up related bugs, so we can focus on solving the root issue, which is part discoverability and part convenience (in the context of a strictly defined namespace).
Status: NEW → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → WONTFIX
(In reply to comment #9)
> Sounds like an argument for a wontfix for this bug, however if the user has
> already been to the page then there's not much point in hiding it further.

Multiple people often use the same computer, and might end up somewhere they absolutely didn't expect. :)

Comment 12

8 years ago
(In reply to comment #11)
> Multiple people often use the same computer, and might end up somewhere they
> absolutely didn't expect. :)

Interesting point, but generally with autocomplete that's not something taken into account.

(In reply to comment #10)
> Right, maybe I should have done a wontfix (still learning :), I just thought it
> would be better to point to the other bug, since it'll essentially solve the
> same problem (in a slightly different way).

Duping to a similar bug that fixes the general issue is actually fine in many instances, but usually after the other bug is in-progress or committed. (and this is usually done by the person implementing the bug in question)
 
> So if I can make a case from the UX side of things, I'd prefer it to not enter
> into regular history, since it would pollute an external namespace (web sites)
> with an internal one (configuration and setting). It's not a good experience
> when about:config shows up in a list together with the links to about.com, for
> instance.

Then a WONTFIX in favor of bug 462674 is probably appropriate here.

Updated

6 years ago
Duplicate of this bug: 777783
You need to log in before you can comment on or make changes to this bug.