Very High Memory Use After Updating to 2.0.0.12

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
11 years ago
10 years ago

People

(Reporter: myng.nospam, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(5 attachments)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

firefox 2.x has shown memory leaking since the beginning but after the recent update to 2.0.0.12 the leaking is out of control. It goes over 372MB of memory and large Virtual Memory usage also.  I'm very dissapointed with this and wish there was a way to revert to the prior release or UNDO or UNINSTALL a recent UPDATE.  Is there?  Firefox becomes sluggish after a while and then sometimes stops responding to keyboard input.  Rarely entirely hangs which is good but still its an annoying problem.  I like to open many window tabs upto 20 at a time and leave them open for days.  Please advise.

Thanks!
Dave

Reproducible: Always

Steps to Reproduce:
1.launch firefox 2.0.0.12 begin surfing, open tabs over time between 10 and 20 tabs
2.allow tabs to remain open for a few hours
3.browsing begins to slowdown. Eventually stops responding to text input/keyboard input. Have to restart firefox. Then problem repeats after a while again.
Actual Results:  
browsing begins to slowdown. Eventually stops responding to text input/keyboard input. Have to restart firefox. Then problem repeats after a while again.

Expected Results:  
browsing remains snappy and fast - considering I have 2GB of RAM and tons of disk space. it should keep running strong and memory usage should not leap up to 300+MB in just a couple of hours.  When I restart firefox and restore the prior session and windows that were open - the memory usage initially is only 128MB or so.

I have 2GB of RAM about 4 GB free on the C: drive where the OS is and some swap space.  This problem started to worsen after recent update to 2.0.0.12.
(Reporter)

Comment 1

11 years ago
Also becomes very slow or unresponsive to tab switching by mouse. Can sometimes get Ctrl-TAB to work.

Keywords: footprint, mlk, perf
Version: unspecified → 2.0 Branch
Component: Software Update → General
QA Contact: software.update → general
Could easily be caused by an incompatible add-on. Please retest in safe-mode to rule this out.
http://kb.mozillazine.org/Safe_Mode_(Firefox)
(Reporter)

Comment 3

11 years ago
I did suspect that beause I also recently installed "Greasemonkey" scripting add-on. But I have since uninstalled it. I also uninstalled something called "Iconix" which is supposed to be like a cheaper version of verisign for authentication of websites and especially emails - adds an icon to your emails to indicate it is official and not spam.  They're software is somewhat overly persistent because although I thought uninstalled it. My firewall asks me if I want to allow Iconix to connect tot he internet when I restart the computer.  

The firefox add-ons I have at this point are: 
*Adblock plus 0.7.5.3
*DOM Inspector 1.8.1.12
*Firefox companion for eBay 1.1.1
*PDF Download 1.0.0.2
*Talkback 2.0.0.12

Here is a link to a screen shot of the firefox add-ons control panel
http://i80.photobucket.com/albums/j188/avrfan/firefox_add-ons-feb-2008.jpg

will be trying safe mode.

Thanks!
Dave
(Reporter)

Comment 4

11 years ago
One more thing: I have had all of these add-ons long before the 2.0.0.12 update and not so much of a problem with memory leak / footprint size of firefox until 2.0.0.12.  Only 2 add-ons which I had added recently just before 2.0.0.12 was Iconix and Greasemonkey - but I have uninstalled those from firefox. Unless they have altered or replaced certain shared files that firefox still uses with a version of their own - is that possible?
(Reporter)

Comment 5

11 years ago
here is a link to screen shot of windows task manager process list showing memory usage and threads etc.

http://i80.photobucket.com/albums/j188/avrfan/firefox_2x_mem_use_feb2008.jpg
(Reporter)

Comment 6

11 years ago
Created attachment 303906 [details]
screen shot of current add-ons control panel
(Reporter)

Comment 7

11 years ago
Created attachment 303907 [details]
screen shot of task manager process list / firefox mem usage
(Reporter)

Comment 8

11 years ago
I haven't tried safe mode yet but mem usuage is upto 459MB now...and virtual memory at 444MB but still running though, occasional partial hanging - not responding for 10 seconds or so.  I'm wondering if it is maybe being caused by ebay assistant add-on.
Well please try Ria's suggestion of safemode, and if that doesn't work, also try making a new profile for a test:
- http://kb.mozillazine.org/Profile_manager
and see if the problem is reproducible with that. But this bug is far too vague to have keywords, and unless you can come up with reproducible steps that start off with firefox 2.0.0.12 and a new profile, then this bug will probably end up getting resolved INVALID.
For more support channels:
- http://forums.mozillazine.org/viewforum.php?f=38
- http://support.mozilla.com/
- irc.mozilla.org #firefox
Keywords: footprint, mlk, perf
(Reporter)

Comment 10

11 years ago
Does the new profile bypass the add-ons in the existing profile?

Thanks,
Dave
Yes, a profile stores all your bookmarks, history, extensions, cookies, etc, so making a new one is like almost like a new installation of Firefox.
(Reporter)

Comment 12

11 years ago
STATUS/UPDATE: I have created a new profile using the Profile Manager and that is what I am using now. It has no add-ons and I have only imported my old bookmarks file from the default profile I was using before.   

I reopened the Tab Group that I was using on the old profile about 20 tabs and memory usage/footprint is up to 147MB to start. Lets see if the leak/memory usage increase behavior continues now.

I will post another status report after some time goes by and I can see if the problem is reproduced.

Is there anything else I should do at this time?  How do I import my old passwords that were saved in the old profile?

Thanks,
Dave
(Reporter)

Comment 13

11 years ago
I figured out how to import my old passwords and webhistory. I did not copy over the preferences files. Just saved passwords,cookies.txt,and history.dat

Will update later about memory usage.

Dave
(Reporter)

Comment 14

11 years ago
Created attachment 304917 [details]
Windows Task Manager - Firefox Memory Use after 24hrs...with new profile

I created a new profile using profile manager and after 24hours memory usage up to nearly 300MB again and beginning to slow down with mouse click and typing and switching tabs again... I have no plugins added at this time, what should I do now?  Do you think firefox 2.0.0.12 maybe really does have a memory leak problem?

Thanks,
Dave
(Reporter)

Comment 15

11 years ago
Created attachment 305888 [details]
Memory Use New Profile Feb 26th (with add-on called download helper)

STATUS UPDATE: Feb 26th 2008. Firefox has been running with multiple tabs (approx 20) open for about 2 days. Memory footprint was holding steady in the Low 200's of MBytes however today Computer began to crawl, browser response times to link clicks etc waaaaay slow. I check Task Manager - FIREFOX MEM USAGE UPTO 400MB.  

I was recently tempted to install an "add-on" called Download Helper. Could I have screwed things up again? I hate this! Am I not allowed to use ADD-ONS with FIREFOX anymore? I think its one the greatest touted features of Firefox and yet we can't use Add-Ons for fear of it causing memory leaks. Can mozilla require certification of plugins like (forgive me for saying this) MS does for certain hardware and software vendors? or create a certification program? One of the requiements is passing a memory use/management test.

What should I do now? Can I disable the Download helper Add-on for when I'm not using it?

It seems to cause a problem with websites that have alot of images on them - here is one in particular my wife goes to and then the memory usage spikes a bit - www.ziare.com

Thanks!
Dave

Comment 16

11 years ago
Mem lick is an old problem - never solved. 
Solution - for now - install Firefox Ultimate Optimizer v1.1, download from :
http://rapidshare.com/files/72110770/firefox-ultimate-optimizer-11.rar

P.S. So your wife is romanian - I am too :-) - best regards !

Comment 17

11 years ago
By the way - did you install 2.0.0.13 ? how does it work?
I had big problem from ..11 to ..12 - it made new profile - had to make a procedure discovered in forum to get it back...
...and yes...12 is still locking sometimes - and it is not because of optimizer - that's how it does anyway with many tabs ( I use ~20 too)
(Reporter)

Comment 18

11 years ago
well, the memory usage with 2.0.0.12 was stabilized after removing all plugins but still would creep up over a very long time, however with 2.0.0.13 it seems a little better.  I have not tried using anyother plugins lately for fear of having memory leak problems again.  Yes my wife is from romania. Are you living in Romania now?  I am thinking to go there this summer for a visit and maybe to look for a job there with computers/IT/tech. I heard the economy and jobs are improving  over there.

Dave
(Reporter)

Comment 19

11 years ago
Well, memory use jumping from 200Mb to 253Mb in a couple of hours of websurfing makes me wonder. I have been viewing youtube videos and other user content video sites with .swv files.  Could there a problem with shockwave content that causes a memory leak with firefox?

thanks,
Dave
(Reporter)

Comment 20

11 years ago
MAYBE I SPOKE TOO SOON... MEMORY USE BACK UP TO 361MB after a couple days and some youtube and websurfing... time to reboot firefox. NO PLUGINS NO EXTENSIONS ADDED AT THIS TIME... running version 2.0.0.13

Comment 21

11 years ago
what version of flash player are you running?
what happens if you install and run with flashblock extension in that clean profile.
(Reporter)

Comment 22

11 years ago
my flash player version is 8.0.22.0 is there a known issue with this some versions and firefox? My mem use after reboot and 1 day is 372Mb now and I haven't played and Youtube content this time, just websurfing. 

I have the Google Desktop installed but not google toolbar.  Google desktop is a desktop application as far as I know but sometimes when you search it opens the results in the default webbrowser which is firefox on my computer.  Is it possible that google desktop plays a roll in memory use? 

I will try the flashblock extension but will I still be able to view Youtube and flash media content?

Thanks,
Dave
To start with, update your flash.. AFAIK the latest version is 9.0r115
(Reporter)

Comment 24

11 years ago
ok, I updated the flash player to the latest version 9.0.1.1.5. I hope that helps but for some reason I don't think it will.

thanks,
Dave
(Reporter)

Comment 25

11 years ago
Created attachment 317946 [details]
Screen Shot of Task Manager showing 700MB of memory use...

computer started crawling. I launch task manager to see mem. usage and shocked to see a record 750MB of memory use by Firefox! This is the latest update 2.0.0.14

Dave
(Reporter)

Comment 26

11 years ago
Well, the snapshot shows 730MB but I just noticed it is at 750MB in less than 5 minutes more... Time for a reboot. Its impressive however that it hasn't totally hanged on me, just getting slow and actually affecting everything on my computer at this point...

Comment 27

11 years ago
Firefox locks up often (many times throughout the day).

Every time Firefox does this, the Firefox.exe process is at 50% (sometimes 49%, sometimes at 51%, but the vast majority of the time, it is 50%).

I started noticing this in the early Version 2.0.
The first couple were fine (2.0), but after the 2nd or 3rd version (like 2.0.0.4), Firefox hangs most of the time.

This can happen by just clicking on another tab, without reloading any web pages and/or going to a different page.

For me, it can last minutes before Firefox starts responding again.

And, when Firefox hangs, ALL Firefox browser windows hang.
No scrolling, can't change tabs, etc.

I have about 4 Firefox windows open.
One of them only had one web page open.
Another has about 30 tabs open.

OS: XPSP2
RAM: 4GB
Current Firefox version: 2.0.0.14

I'm thinking about uninstalling Firefox and going back to one of the earlier ones.
(Reporter)

Comment 28

11 years ago
hi, I am the guy who started this bug report.  My main issue had to do with memory use getting very high with many tabs open over time, leading to slow responding or partial hanging of firefox. It has very extremely rarely completely hanged on me but I started with about 512MB of RAM and now I have 2GB of RAM. It will go longer and more stable with the extra RAM. I believe because when you have a memory leak problem with software that you are running, the computer will begin to become unstable as you run low on memory resource.  Have you looked in the Task Manager Process viewer to see how much memory is being used by firefox? I have seen my usage sometimes go as high as 750MB.  It also depends what other programs are running which also use memory.

Now I restart firefox at about 350MB but I have a new problem - the process doesn't terminate, even though all the windows are closed. This is after updating to 2.0.0.14 also, so I think perhaps you are right that the latest version is not as stable as the ealier ones but how do we back out to an earlier install? Do we  run the installer for the older version first or do we uninstall our existing version first? My main worry is losing all my settings, bookmarks and saved logins and form data.

Dave

Comment 29

11 years ago
Firefox hangs even after rebooting Firefox or rebooting the entire system.

There is nothing else open except 5 Firefox windows.

Firefox.exe is currently using:
Memory usage is 306,836K
CPU at 50%

Firefox.exe is using the most memory out of all processes running.

I have 4 GB of RAM, so 307 MB should not impact performance like this.
The CPU is a dual core Pentium 2.8GHz.

I had uninstalled Firefox 2.0.0.14 and re-installed Firefox 1.5.0.2.

It did not hang like Firefox 2.0.x does.

But, 1.5.0.2 does not seem to work with some sites, like http://www.mycokerewards.com.

I re-installed 2.0.0.14.

Most of the time, the entire browser locks up.
But, on a few occasions, including now, if I click on a tab, it will not change to that tab, but on the drop down list on the right hand side of the tab row, I can select the tab I want to go to and it goes right away.

NOTE: most of the time, this part is locked up too.

But, maybe an area to look into as to why clicking on a tab does not work, but the drop down list does.

Also note, the tabs highlight when the mouse pointer is hovering over them, but clicking does not change the tab, or it is a very long, delayed response.

Other times, everything is locked up on Firefox, like hovering over the menu bar, etc. does not "bubble up" showing which one the mouse is pointing to.

Comment 30

10 years ago
Dave, how is your situation with FF3?

Comment 31

10 years ago
=> incomplete due to no response from dave
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.