Folder animation inconsistent in places, folders stay open when navigating to new one.

RESOLVED WONTFIX

Status

()

Firefox
Bookmarks & History
RESOLVED WONTFIX
11 years ago
9 years ago

People

(Reporter: Recall, Unassigned)

Tracking

({useless-UI})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021704 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021704 Minefield/3.0b4pre

In places, if you click a folder in the left or right pane, then it will not show the open animation. However, if you double click, it will show the open animation. The problem is when choosing another folder, the previous one keeps its open animation. 

I expect it to show the folder closed when you choose a second folder, and not requiring a double click to initiate the animation.

Reproducible: Always

Steps to Reproduce:
1.Double click a folder in left pane
2. Navigate to another folder
3. Or alternatively single click and the open animation does not even occur!
Actual Results:  
Folders stay open on double click and navigating to new folder, or do not animate on single click

Expected Results:  
Folders animate as open on single click and close when navigating to a new folder.
(Reporter)

Updated

11 years ago
Keywords: useless-UI

Comment 1

10 years ago
I don't want the first folder to automatically collapse when I open another folder.

Comment 2

10 years ago
single click is select, while if you want it to open you should single click on the [+] near the container. this is by design and will not change.

about closing other containers when opening one it's again a design choice, you must be able to reorder your bookmarks through drag & drop, and to drop a bookmark in the middle of a folder, at the desired position. So at a maximum that could be done with an hidden pref.

imho this is a wontfix since it would regress drag & drop reordering in the bookmarks sidebar, but if you have better reasons file them.

Updated

10 years ago
Whiteboard: wontfix?
WONTFIX per comments #1 and #2.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
Whiteboard: wontfix?
Bug 451915 - move Firefox/Places bugs to Firefox/Bookmarks and History. Remove all bugspam from this move by filtering for the string "places-to-b-and-h".

In Thunderbird 3.0b, you do that as follows:
Tools | Message Filters
Make sure the correct account is selected. Click "New"
Conditions: Body   contains   places-to-b-and-h
Change the action to "Delete Message".
Select "Manually Run" from the dropdown at the top.
Click OK.

Select the filter in the list, make sure "Inbox" is selected at the bottom, and click "Run Now". This should delete all the bugspam. You can then delete the filter.

Gerv
Component: Places → Bookmarks & History
QA Contact: places → bookmarks
You need to log in before you can comment on or make changes to this bug.