Firefox 3.0b3 hangs on launch after it's run once. After machine reboot it will run once.

VERIFIED DUPLICATE of bug 416232

Status

()

Firefox
General
--
critical
VERIFIED DUPLICATE of bug 416232
10 years ago
10 years ago

People

(Reporter: Mike Bowler, Unassigned)

Tracking

({hang})

Trunk
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.11) Gecko/20071128 Camino/1.5.4
Build Identifier: http://www.mozilla.com/en-US/products/download.html?product=firefox-3.0b3&os=osx&lang=en-US

After an OS reboot, the browser will launch successfully once.  If it's shut down or if it crashes, it will hang on every attempt to launch it until the OS is rebooted again.

On an attempted launch, the icon in the dock will bounce for a while and then stop.  CPU usage goes to 100% and stays there.  No window appears.

This machine has run every version of the 3.0 alphas and betas and this is the first time I've had problems like this.  I first saw the problem when upgrading from beta 2 to beta 3 and had thought that the upgrade had just failed.

I then did a fresh install of 3.0b3 and saw the same problem so I'm guessing it wasn't the upgrade.

I've tried launching it with the -safemode flag but that didn't make a difference.

Reproducible: Always

Steps to Reproduce:
1. Run Firefox.
2. Shut it down
3. Try to run it again
Actual Results:  
Firefox hangs

Expected Results:  
It should have displayed a browser window.

I've been using the new OS/X them (I can't remember the proper name and can't start Firefox to see).  OS/X version 10.4.11

Comment 1

10 years ago
Have you checked the activity monitor (Applications>Utilities) and made sure that no other Firefox processes are running?  Is anyone else logged in to your computer (locally or remotely)?
(Reporter)

Comment 2

10 years ago
Activity monitor reports that only one copy of firebox-bin is running.

There is only one user logged into the machine locally (myself) and nobody logged in remotely.

Updated

10 years ago
Version: unspecified → Trunk

Comment 3

10 years ago
Make a sample with the activity monitor (inspect -> sample) and attach it here.

Is it really reporting firefox-bin running?  It should just report Firefox and nothing else once browser startup has gotten far enough.  Does Firefox show up at all?
Keywords: hang
Hardware: Macintosh → PC
(Reporter)

Comment 4

10 years ago
Created attachment 304223 [details]
Sample from activity monitor
(Reporter)

Comment 5

10 years ago
It reports "Firefox (not responding)" in the list.  I've attached a sample from activity monitor.

Comment 6

10 years ago
Terribly sorry, this one was my bad.  Fix is checked in.  If you could, could you try a latest trunk build to verify that it's fixed on your machine?  
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 416232
(Reporter)

Comment 7

10 years ago
I'm posting this with the nightly build.  The problem is fixed - thanks.
Resolution: DUPLICATE → FIXED
Mike this is a DUPE, please don't change its resolution.
Resolution: FIXED → DUPLICATE
Duplicate of bug: 416232
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.