Firefox crashes when trying to open new tabs or windows (every 5 minutes or so)

RESOLVED DUPLICATE of bug 404787

Status

()

Core
DOM
--
critical
RESOLVED DUPLICATE of bug 404787
10 years ago
10 years ago

People

(Reporter: gebozinis, Unassigned)

Tracking

1.8 Branch
x86
Windows Vista
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 obsolete attachment)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.12) Gecko/20080201 Firefox/2.0.0.12

Firefox crashes every 5 minutes or so, usually when I try to open a new tab or window. My OS is Vista x64 Ultimate. 

The problem will show up (many times) in Talkback, but it never gets sent, so I will attach the Talkback report.

Also I posted Windows Vista's error from the Event Viewer.

Reproducible: Always

Steps to Reproduce:
1. Usually happens when trying to open a new tab or window
2. It happens very frequently, it is a major annoyance
3.



[From Vista's Event Viewer]
-------------------------------

Faulting application firefox.exe, version 1.8.20080.20121, time stamp 0x47a4062e, faulting module js3250.dll, version 4.0.0.0, time stamp 0x47a40804, exception code 0xc0000005, fault offset 0x00031fcf, process id 0x21c, application start time 0x01c870dfa1749fe4.
(Reporter)

Comment 1

10 years ago
Created attachment 303899 [details]
Talkback report

This is a Talkback report (one of many) that never gets sent

Comment 2

10 years ago
Comment on attachment 303899 [details]
Talkback report

we can't use this. it's merely showing you the information it would like to send so that if you're paranoid you can confirm there's nothing useful in it. however until the information reaches the server, it isn't meaningful to anyone and there's no way to take the text format of that data and submit it to the server.
Attachment #303899 - Attachment is obsolete: true
(Reporter)

Comment 3

10 years ago
Talkback sent some of these finally, these are the Incident IDs:

TB41575058X
TB41575056G
TB41575054W

Comment 4

10 years ago
well, that sucked. i was able to read your reports once, but when i checked again two out of three had gone awol.

fwiw, one was Detecting (which is a dupe), I can't remember what the other was but it was in this family of dom event handling crashes (all of which are dupes)

Incident ID: 41575054
Stack Signature	js_LookupPropertyWithFlags 4c0208a1
Product ID	Firefox2
Build ID	2008020121
Trigger Time	2008-02-17 04:31:20.0
Platform	Win32
Operating System	Windows NT 6.0 build 6001
Module	js3250.dll + (00031fcf)
URL visited	
User Comments	
Since Last Crash	240437 sec
Total Uptime	240437 sec
Trigger Reason	Access violation
Source File, Line No.	c:/builds/tinderbox/Fx-Mozilla1.8-Release/WINNT_5.2_Depend/mozilla/js/src/jsobj.c, line 3247
Stack Trace 	
js_LookupPropertyWithFlags  [mozilla/js/src/jsobj.c, line 3247]
js_LookupProperty  [mozilla/js/src/jsobj.c, line 3174]
js_GetProperty  [mozilla/js/src/jsobj.c, line 3552]
nsXPCWrappedJSClass::CallQueryInterfaceOnJSObject  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 243]
nsXPCWrappedJSClass::DelegatedQueryInterface  [mozilla/js/src/xpconnect/src/xpcwrappedjsclass.cpp, line 633]
nsXPCWrappedJS::QueryInterface  [mozilla/js/src/xpconnect/src/xpcwrappedjs.cpp, line 106]
nsEventListenerManager::HandleEvent  [mozilla/content/events/src/nsEventListenerManager.cpp, line 1752]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2234]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2257]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2257]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2257]
nsXULElement::HandleDOMEvent  [mozilla/content/xul/content/src/nsXULElement.cpp, line 2257]
nsEventStateManager::DispatchMouseEvent  [mozilla/content/events/src/nsEventStateManager.cpp, line 2797]
nsEventStateManager::NotifyMouseOut  [mozilla/content/events/src/nsEventStateManager.cpp, line 2866]
nsEventStateManager::NotifyMouseOver  [mozilla/content/events/src/nsEventStateManager.cpp, line 2915]
nsEventStateManager::GenerateMouseEnterExit  [mozilla/content/events/src/nsEventStateManager.cpp, line 2954]
nsEventStateManager::PreHandleEvent  [mozilla/content/events/src/nsEventStateManager.cpp, line 567]
PresShell::HandleEventInternal  [mozilla/layout/base/nsPresShell.cpp, line 6515]
PresShell::HandleEvent  [mozilla/layout/base/nsPresShell.cpp, line 6356]
nsViewManager::HandleEvent  [mozilla/view/src/nsViewManager.cpp, line 2566]
nsViewManager::DispatchEvent  [mozilla/view/src/nsViewManager.cpp, line 2253]
HandleEvent  [mozilla/view/src/nsView.cpp, line 174]
nsWindow::DispatchEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 1319]
nsWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6329]
ChildWindow::DispatchMouseEvent  [mozilla/widget/src/windows/nsWindow.cpp, line 6576]
nsWindow::WindowProc  [mozilla/widget/src/windows/nsWindow.cpp, line 1507]
USER32.dll + 0x18807 (0x75828807)
USER32.dll + 0x18962 (0x75828962)
USER32.dll + 0x18aad (0x75828aad)
USER32.dll + 0x18b00 (0x75828b00)
nsAppShell::Run  [mozilla/widget/src/windows/nsAppShell.cpp, line 159]
nsAppStartup::Run  [mozilla/toolkit/components/startup/src/nsAppStartup.cpp, line 152]
main  [mozilla/browser/app/nsBrowserApp.cpp, line 61]
kernel32.dll + 0x8e3f3 (0x7700e3f3)
ntdll.dll + 0x7cfed (0x774fcfed)
ntdll.dll + 0x7d1ff (0x774fd1ff)
Component: General → DOM
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.8 Branch
(Reporter)

Comment 5

10 years ago
Hey timeless,

The reports are there, these are the (same) links:
http://talkback-public.mozilla.org/search/start.jsp?search=2&type=iid&id=TB41575058X
http://talkback-public.mozilla.org/search/start.jsp?search=2&type=iid&id=TB41575056G
http://talkback-public.mozilla.org/search/start.jsp?search=2&type=iid&id=TB41575054W

Two of them have a reference to js3250.dll (one of these two is the one you posted).

I don't have the slightest idea about how I should interpret this information or even what to do or where to start. Most of the times when Mozilla crashes in this fashion, Talkback will not get triggered. I have read several (20 or 30) similar or identical complaints/reports spread out over the Internet and it is my understanding that this bug doesn't get fixed because it rarely triggers Talkback. The funny thing is that some of the reports are related to Firefox version 1.X.

Comment 6

10 years ago
actually, i'm not sure i recognize this one... it's bug 407749

Incident ID: 41575058
Stack Signature	0x53740022 cde6e9ef
Product ID	Firefox2
Build ID	2008020121
Trigger Time	2008-02-17 11:43:07.0
Platform	Win32
Operating System	Windows NT 6.0 build 6001
Module	
URL visited	
User Comments	
Since Last Crash	1134 sec
Total Uptime	266238 sec
Trigger Reason	Access violation
Source File, Line No.	N/A
Stack Trace 	
0x53740022
nsQueryInterface::operator()  [mozilla/xpcom/build/nsCOMPtr.cpp, line 52]
nsXBLService::GetBinding  [mozilla/content/xbl/src/nsXBLService.cpp, line 854]
nsXBLService::GetBinding  [mozilla/content/xbl/src/nsXBLService.cpp, line 908]
nsXBLService::GetBinding  [mozilla/content/xbl/src/nsXBLService.cpp, line 908]
nsXBLService::LoadBindings  [mozilla/content/xbl/src/nsXBLService.cpp, line 585]
nsElementSH::PostCreate  [mozilla/dom/src/base/nsDOMClassInfo.cpp, line 7052]
XPCWrappedNative::GetNewOrUsed  [mozilla/js/src/xpconnect/src/xpcwrappednative.cpp, line 467]
XPCConvert::NativeInterface2JSObject  [mozilla/js/src/xpconnect/src/xpcconvert.cpp, line 1156]
nsXPConnect::WrapNative  [mozilla/js/src/xpconnect/src/nsXPConnect.cpp, line 597]
nsDOMClassInfo::WrapNative  [mozilla/dom/src/base/nsDOMClassInfo.cpp, line 1413]
nsArraySH::GetProperty  [mozilla/dom/src/base/nsDOMClassInfo.cpp, line 7172]
XPC_WN_Helper_GetProperty  [mozilla/js/src/xpconnect/src/xpcwrappednativejsops.cpp, line 953]
js_NativeGet  [mozilla/js/src/jsobj.c, line 3469]
js_GetProperty  [mozilla/js/src/jsobj.c, line 3616]
js_Interpret  [mozilla/js/src/jsinterp.c, line 3717]
js_Invoke  [mozilla/js/src/jsinterp.c, line 1398]
js_InternalInvoke  [mozilla/js/src/jsinterp.c, line 1473]
JS_CallFunctionValue  [mozilla/js/src/jsapi.c, line 4353]
nsJSContext::CallEventHandler  [mozilla/dom/src/base/nsJSEnvironment.cpp, line 1493]

Detecting is bug 319533.
js_LookupPropertyWithFlags is bug 404787

take your pick.
(Reporter)

Comment 7

10 years ago
Hey timeless,

I think that you are asking me which bug is worst, that would definitely be the one related to js_LookupPropertyWithFlags, because I am assuming that it is the primary reason for the constant crashing.

About the Talkbalk not getting triggered, it is a minor annoyance, just makes it harder to report bugs.

Comment 8

10 years ago
pretty much.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 404787
You need to log in before you can comment on or make changes to this bug.