text munged going from HTML Source to Normal mode

VERIFIED WORKSFORME

Status

()

Core
Editor
P3
normal
VERIFIED WORKSFORME
18 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: dcone (gone))

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
minor repaint issue, which i saw consistently on Mac OS 9.0 and sometimes on
winNT [2000.06.06.08 opt bits]. minimizing then restoring the window repaints
the text correctly.

1. open a blank editor window and type some text.
2. toggle on the Edit Mode tabs.
3. go from Normal (where you should be initially) and click the HTML Source tab.
4. go back to Normal mode.

result: the text appears munged.
workaround: minimize and restore the window.

Updated

18 years ago
Assignee: beppe → kmcclusk

Comment 1

18 years ago
assigning this to Kevin, it looks like it is a repaint issue of some sort
When I switch to HTML mode all of the text that I've entered disappears. 
Toggling back to normal mode does not bring it back. Minimizing and restoring 
the composer window does not bring it back either.
Using  6/6/2000 build on WINNT.


Reassigning to beppe

Beth reassign back to me when the disappearing text issue has been resolved.
Assignee: kmcclusk → beppe

Comment 3

18 years ago
this is't a Mac only problem, it also happens on win32, not sure about linux. 
I'm raising the priority on this one and nominating for dogfood+ -- loosing data 
is a very bad thing
Severity: minor → major
Keywords: dogfood
Priority: P3 → P2
Summary: text munged going from HTML Source to Normal mode → text gets deleted when toggle between modes
Target Milestone: --- → M16

Comment 4

18 years ago
oops I forgot we already had a delete bug that jfrancis is working on, marking 
this one dependent on that one and removing the dogfood keyword. Munging happens 
differently on other platforms too.
Severity: major → normal
Depends on: 41369
Keywords: dogfood
Priority: P2 → P3
Summary: text gets deleted when toggle between modes → text munged going from HTML Source to Normal mode

Comment 5

18 years ago
back to Kevin, the dependency bug is resolved
Assignee: beppe → kmcclusk
Don could you take a look at this on Mac. It works correctly on WIN32?
Assignee: kmcclusk → dcone

Comment 7

18 years ago
M16 has been out for a while now, these bugs target milestones need to be 
updated.
(Assignee)

Comment 8

18 years ago
Tested on the Mac.. seems everything works correctly.. the text was as I typed 
after switching a few times.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 9

18 years ago
verified in 7/21 build.
Status: RESOLVED → VERIFIED

Comment 10

13 years ago
http://www.justdave.net/dave/article.php?story=20050107003727277 -> Fixing
OS: All
Hardware: Macintosh → All
You need to log in before you can comment on or make changes to this bug.