Closed Bug 418149 Opened 14 years ago Closed 14 years ago

Right Clicking on menu items in bookmarks toolbar should bring up a contextual menu

Categories

(Firefox :: Bookmarks & History, enhancement)

PowerPC
macOS
enhancement
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 300710

People

(Reporter: adil, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008021704 Minefield/3.0b4pre
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X 10.4; en-US; rv:1.9b4pre) Gecko/2008021704 Minefield/3.0b4pre

When I organise bookmarks in the bookmarks toolbar into a folder the contents appear as a menu in the toolbar. If I right-click on the toolbar button - I get a contextual menu letting me acccess the properties of that item.

If I click on the folder in the toolbar I get a menu of the bookmarks inside folder. Right-clicking on any of these bookmarks in the menu should give me a contextual menu but it does the action of left-clicking and goes to the bookmarked page.

Reproducible: Always

Steps to Reproduce:
1. Create a folder in the Bookmarks Toolbar folder in the Bookmarks area.
2. Fill this folder with Bookmarks
3. Click on the folder in the Toolbar to get a pop-up menu of bookmarks
4. Right-click any item in this menu
Actual Results:  
Firefox goes to the web page that is bookmarked

Expected Results:  
A contextual menu to access the properties of the bookmark

Now that FF 3 b4 is allowing drag and drop in the Bookmark menus it should really allow right-clicked contextual menus to be consistent with the Windows version.
Version: unspecified → Trunk
WFM on Vista HP 

Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9b4pre) Gecko/2008021704 Minefield/3.0b4pre Firefox/3.0 ID:2008021704
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 300710
You need to log in before you can comment on or make changes to this bug.