Closed Bug 418169 Opened 12 years ago Closed 12 years ago

Cmd + B opens Bookmark Manager instead of making text bold in Google Docs

Categories

(Camino Graveyard :: General, defect)

PowerPC
macOS
defect
Not set

Tracking

(Not tracked)

VERIFIED WONTFIX

People

(Reporter: steven, Unassigned)

References

()

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b4pre) Gecko/2008021700 Camino/2.0a1pre (like Firefox/3.0b4pre)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en; rv:1.9b4pre) Gecko/2008021700 Camino/2.0a1pre (like Firefox/3.0b4pre)

While using Google Docs, pressing Cmd + B opens the Bookmark Manager instead of marking the selected text bold. It also not trigger the bold function when pressing Cmd + B (It opens the Bookmark manager).

Reproducible: Always

Steps to Reproduce:
1. Open a doc in Google Docs.
2. Press Cmd + B.
3. Watch as the Bookmark Manger is opened and the bold function is not turned on in Google Docs.
Actual Results:  
The Bookmark Manager opens.

Expected Results:  
The bold function of Google Docs to turn on when Cmd + B is pressed.
Summary: Cmd + B opens Bookmark Manager instead of making text bold → Cmd + B opens Bookmark Manager instead of making text bold in Google Docs
I have also noticed that many more of the keyboard shortcuts do not work. Here is the list:

http://docs.google.com/support/bin/answer.py?answer=66280&topic=8634
The help page you linked to lists those all as control-key, not command-key, so the behavior you describe does not appear to be a bug.

Control doesn't work either though; does it work in Minefield? (And don't we have this filed already, or did it just come up recently in another bug?)
Safari/WebKit has the keyboard shortcut as Cmd + shortcut and some of the shortcuts for Camino ARE Cmd + shortcut (such as Cmd + A). 

Cmd + shortcut and Ctrl + shortcut do not work in the latest Minefield nightly.
(In reply to comment #2)
> Control doesn't work either though; does it work in Minefield?

Focus bug?

> (And don't we
> have this filed already, or did it just come up recently in another bug?)

I looked and couldn't find it (although I thought I remembered that the issue there was Ctrl not working on the entire cell vs the selected text).

(In reply to comment #3)
> Safari/WebKit has the keyboard shortcut as Cmd + shortcut and some of the
> shortcuts for Camino ARE Cmd + shortcut (such as Cmd + A).

There is no way we would allow a web page to override our own menu shortcuts, and I'd be surprised if Safari did (Safari has no built-in binding for Command-B; we do). Would you really want web pages that couldn't be closed from the keyboard, because they stole Command-W?

The specific behavior this bug is filed about is WONTFIX. If there aren't already core bugs for control key shortcuts not working, those should be filed as new bugs.
Status: UNCONFIRMED → RESOLVED
Closed: 12 years ago
Resolution: --- → WONTFIX
I was not asking for you to allow a web page to override current menu shortcuts, but to allow sites that had advanced functionality such as Google Docs to use normal program key commands such as Cmd + B, so that it has the same functionality as regular word processors, like it is supposed to. Google Docs (nor any other web app that I know of) uses Cmd + W (or Q) for a function, nor anyone would expect it to. 

This was a simple request/bug to allow desktop application-like functionality for web-based applications like Google Docs, like it is supposed to. Camino hinders this functionality. 
(In reply to comment #6)
> I was not asking for you to allow a web page to override current menu
> shortcuts, but to allow sites that had advanced functionality such as Google
> Docs to use normal program key commands such as Cmd + B, so that it has the
> same functionality as regular word processors, like it is supposed to. Google
> Docs (nor any other web app that I know of) uses Cmd + W (or Q) for a function,
> nor anyone would expect it to. 

One of Camino's menu shortcuts is cmd-b. If we allowed Google Docs (and other apps) to use this shortcut, we'd have to disallow Camino to use this shortcut. And without going in and enabling every shortcut we'd want specific web apps to support, there'd be nothing stopping a webpage from declaring cmd-w, cmd-q, or any other shortcut key theirs, whether we "expect it" or not.
Status: RESOLVED → VERIFIED
I'm not trying to pick a fight or anything here, but you could always do what Safari/WebKit did and just make the bookmark manager appear with Option + Cmd + B and leave the Cmd + B open for web applications that want to mimic desktop functionality. With web applications that mimic their desktop counterpart becoming more popular this would become more of an issue, you don't press Ctrl + B in Pages/Word to make text bold, you press Cmd + B. You could also leave the other standard desktop application buttons free, such as Cmd + U, Cmd + I, etc., for web applications to use that want to mimic that ability.
(In reply to comment #6)
> I was not asking for you to allow a web page to override current menu
> shortcuts

If you look at your "Actual Results" and "Expected Results" again, you'll see
that what you are asking for is exactly that. Allowing web pages to disable the
bookmark manager shortcut isn't any more acceptable than allowing them to
disable closing the window.

> This was a simple request/bug to allow desktop application-like functionality
> for web-based applications like Google Docs, like it is supposed to.

Giving sites capabilities that allow them to reduce the usability of the
browser as a whole is absolutely not something that that Camino is "supposed
to" do. If you want full chrome access for web pages, you should be using
specialized wrappers for those pages, which have an intrinsic trust system.

(In reply to comment #8)
> You could also leave the other standard desktop application buttons free,
> such as Cmd + U, Cmd + I, etc., for web applications to use that want to
> mimic that ability.

We are not going to remove every single potentially meaningful shortcut from Camino just because some page might want to use it. Again, if you want a web page that behaves just like a desktop application, use a specialized wrapper for it. Camino is not a web application platform, it's a general-purpose browser.

This bug has been WONTFIXed, and that decision stands.
(In reply to comment #9) 
> If you look at your "Actual Results" and "Expected Results" again, you'll see
> that what you are asking for is exactly that. Allowing web pages to disable the
> bookmark manager shortcut isn't any more acceptable than allowing them to
> disable closing the window.

Here's the proper suggestion then:
Change the Bookmark Manager shortcut to Option + Cmd + B to allow websites like Google Docs and Zoho (as well as other websites) to use Cmd + B.

> Giving sites capabilities that allow them to reduce the usability of the
> browser as a whole is absolutely not something that that Camino is "supposed
> to" do. If you want full chrome access for web pages, you should be using
> specialized wrappers for those pages, which have an intrinsic trust system.

How is changing a shortcut command reducing the usability of a browser? Safari/WebKit does it and it is just as usable as Camino is. 

> We are not going to remove every single potentially meaningful shortcut from
> Camino just because some page might want to use it. Again, if you want a web
> page that behaves just like a desktop application, use a specialized wrapper
> for it. Camino is not a web application platform, it's a general-purpose
> browser.

I'm not asking you remove "every single potentially meaningful shortcut" but but just ones that certain sites like Google Docs and Zoho use (as well as other sites) frequently, to enhance the usability of that website.

> This bug has been WONTFIXed, and that decision stands.
I understand that, but I am just trying to get my point across. Camino is a hinderance to websites like these and if these types of websites continue to become popular, then Camino will become unusable for users who frequent these sites.
(In reply to comment #10)
> How is changing a shortcut command reducing the usability of a browser?
> Safari/WebKit does it and it is just as usable as Camino is. 

Requiring more keys to be pressed isn't "just as usable", in my opinion.

> I'm not asking you remove "every single potentially meaningful shortcut" but
> but just ones that certain sites like Google Docs and Zoho use (as well as
> other sites) frequently, to enhance the usability of that website.

But you are! :)

For example, cmd-i makes perfect sense as "page info" since many applications use it. Changing our shortcut is *less* usable and removes meaning from the shortcut.

> I understand that, but I am just trying to get my point across. Camino is a
> hinderance to websites like these and if these types of websites continue to
> become popular, then Camino will become unusable for users who frequent these
> sites.

Unusable? ctrl-b is really that hard?
(In reply to comment #11)
> Requiring more keys to be pressed isn't "just as usable", in my opinion.

It all comes down to personal preference really. I was just submitting an idea, but didn't expect for it to be shot down so quickly with very little discussion.

> But you are! :)
> 
> For example, cmd-i makes perfect sense as "page info" since many applications
> use it. Changing our shortcut is *less* usable and removes meaning from the
> shortcut.

But I am not! I was just giving random examples, but I never did say that you should leave all 26 letters open for random web applications to use. Personally, I have never used Cmd + I to "Get Info" on a page, only for Google Docs/Zoho italics. Again, personal preference.

> Unusable? ctrl-b is really that hard?

To be honest, on a MBP Ctrl + B is harder to hit than Cmd + B, but as I have said so many times, its personal preference. On Windows and Linux, the Bookmark Manager for Firefox is Ctrl + B, but on Mac its Cmd + B, why change it, why not leave it as Ctrl + B? (This argument could go on forever, but I'm just saying why inhibit websites such as GD and Zoho from simple shortcuts such as those?)
(In reply to comment #12)
> To be honest, on a MBP Ctrl + B is harder to hit than Cmd + B, but as I have
> said so many times, its personal preference. On Windows and Linux, the Bookmark
> Manager for Firefox is Ctrl + B, but on Mac its Cmd + B, why change it, why not
> leave it as Ctrl + B?

Because, on Mac, the main "command" key for shortcuts is cmd. On Windows, it's ctrl. Just because ctrl on Mac and ctrl on Windows have the same name doesn't mean they're the same key. (Consider copy/paste on Mac and Windows.)

This is hardly relevant to this discussion though.

I don't think you were "shot down", I think we've long decided what our shortcuts are. They make sense and they're consistent with the OS and other apps, with some variants. Changing our behavior to cater to web apps that might very well change their behavior (as web apps do over time) doesn't really make sense. It would involve disrupting every user who's used to cmd-b opening the Bookmark manager to give "benefit" to a subsection of users who might use web apps that want special shortcuts. For me, using a MBP, I don't have any trouble reaching ctrl when I need it, which is far less than I need cmd for the many other features I use. 
(In reply to comment #10)
> > This bug has been WONTFIXed, and that decision stands.
> I understand that, but I am just trying to get my point across.

Your point has been made, and the bug has been WONTFIXed. Continuing to argue that you believe that we are wrong is neither productive, nor appropriate for bugzilla.
You need to log in before you can comment on or make changes to this bug.